Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-117117

Email domain validation doesn't work as expected for the first added user

    Details

      Description

      Steps to reproduce:

      1. Enable Email Domain Validation
      2. Add an account with a set domain
      3. Go to Account Users portlet
      4. Add an account user to account

      Expected results: View Valid Domains link under Email Address field is present
      Actual results: Missing View Valid Domains link

      1. Input an email with a different domain than the one set in step 2

      Expected results: Warning displays stating email is not a valid domain for the account assigned to user
      Actual results: No warning displays for the first account user; email domain validation works as expected for the second user to be added

      Reproduced on:
      Tomcat 9.0.33 + MySQL 5.7
      Portal master GIT ID: 76f17290c7dd17e02dbd73c3babb438de273a272

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              support-lep@liferay.com SE Support
              Reporter:
              patricia.perez Patricia Perez
              Participants of an Issue:
              Recent user:
              Sharry Shi
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Days since last comment:
                1 week, 1 day ago

                  Packages

                  Version Package