Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-11821

Document library portlet accepts different file extensions for document versioning

    Details

    • Type: Regression Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 6.0.5 GA
    • Fix Version/s: --Sprint - SP, 6.1.0 CE RC1
    • Component/s: DM
    • Labels:
      None
    • Environment:
      Tomcat+ mysql revision 59500, firefox

      Description

      Add Document Library > Add Document with *.txt extension.

      edit the document and load a document with *jpg extension.

      It should not allow you to load a jpg as a version for a txt document.

        Activity

        jorge.ferrer Jorge Ferrer added a comment -

        This is not a bug. There is a property that allows or disallows this behavior:

        #

        1. Set this to false to allow users to update file entries by uploading a
        2. file with an extension different from the one of the originally uploaded
        3. file. There is a known issue where setting this to true will break OSX
        4. compatibility. See LPS-10770 for more information.
          #
          dl.file.extensions.strict.check=false

          People

          • Assignee:
            jorge.ferrer Jorge Ferrer
            Reporter:
            lawrence.lee Lawrence Lee
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              6 years, 19 weeks ago

              Development

                Subcomponents