PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-11854

Web Form Portlet Configuration -- Changing type field does not appear to work at all in IE8.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.0.4 GA, 6.0.5 GA, 6.0.12 EE, 6.1.0 CE RC1
    • Fix Version/s: 6.0.12 EE
    • Component/s: Web Form
    • Labels:
      None
    • Environment:
      Tomcat 6.0. + MySQL. IE8. 4.0.0. 6.0.x. Revision 78625.
      Tomcat 6.0. + MySQL. IE8. 4.0.0. Trunk. Revision 78625.
    • Branch Version/s:
      6.0.x
    • Backported to Branch:
      Committed
    • Liferay Contributor's Agreement:
      Accept
    • Similar Issues:
      Show 4 results 

      Description

      When you are configuring a web form portlet changing the Type field on a question should change the type of fields visible. For instance if the Type is "Options" then an additional "Options" text box should appear. If the type is "Text" then this "Options" text box should not appear.

      Currently in 6.04 GA if you change the type in IE8 the options are not updating properly. (As in the Option field is not appearing and disappearing when it should). I also tested this in IE7 mode using the IE developer tools and encountered the same issue. Using the mouse to change them in Firefox and Google Chrome appears to work fine, so the problem appears to be related just to IE. Note though that using the keyboard does not work in Firefox or Google Chrome and a separate bug has been filed for that. (See: LPS-11853)

      This used to work in 5.2.3 for sure so this appears to have regressed.

      1. LPS-11854-build-73994.patch
        0.7 kB
        Deb Troxel
      2. LPS-11854-build-73994.patch
        0.7 kB
        Deb Troxel

        Issue Links

          Activity

          Hide
          Deb Troxel added a comment -

          Hi Sean,

          Can you please verify
          1) when the patch isn't installed you don't have the double-select problem
          2) when the patch is installed the problem only happens on the configuration form select fields and not other select boxes (such as the "Rating" field on the default web form).

          I've retested on IE using 8.0.7600.16385 and 8.0.7601.17514 with compatibility view on and off, but I can't reproduce what you saw. I was wondering if something else might have caused the problem for you. Can you please make sure that it only happens with the patched code and not otherwise?

          Thanks!

          • Deb
          Show
          Deb Troxel added a comment - Hi Sean, Can you please verify 1) when the patch isn't installed you don't have the double-select problem 2) when the patch is installed the problem only happens on the configuration form select fields and not other select boxes (such as the "Rating" field on the default web form). I've retested on IE using 8.0.7600.16385 and 8.0.7601.17514 with compatibility view on and off, but I can't reproduce what you saw. I was wondering if something else might have caused the problem for you. Can you please make sure that it only happens with the patched code and not otherwise? Thanks! Deb
          Hide
          Sean McClelland added a comment -

          Hi Deb,

          Sorry my mistake. It looks like whatever issue I am having with IE happens before the patch is installed. I encountered the same double clicking problem on a fresh install of Liferay 6.0.6 Community Edition so it is definitely not related to the patch. I have marked this patch as accepted.

          Thanks for all of your help!

          -Sean

          Show
          Sean McClelland added a comment - Hi Deb, Sorry my mistake. It looks like whatever issue I am having with IE happens before the patch is installed. I encountered the same double clicking problem on a fresh install of Liferay 6.0.6 Community Edition so it is definitely not related to the patch. I have marked this patch as accepted. Thanks for all of your help! -Sean
          Hide
          Deb Troxel added a comment -

          Sean,

          No problem. Thanks for your quick follow-up.

          • Deb
          Show
          Deb Troxel added a comment - Sean, No problem. Thanks for your quick follow-up. Deb
          Hide
          Paul Piao (Inactive) added a comment -

          Able to reproduce on
          Tomcat 6.0. + MySQL. IE8. 4.0.0. 6.0.x. Revision 78625.
          Tomcat 6.0. + MySQL. IE8. 4.0.0. Trunk. Revision 78625.

          Show
          Paul Piao (Inactive) added a comment - Able to reproduce on Tomcat 6.0. + MySQL. IE8. 4.0.0. 6.0.x. Revision 78625. Tomcat 6.0. + MySQL. IE8. 4.0.0. Trunk. Revision 78625.
          Hide
          Vicki Tsang (Inactive) added a comment -

          This is being bulk closed in preparation for the new workflow.

          Show
          Vicki Tsang (Inactive) added a comment - This is being bulk closed in preparation for the new workflow.

            People

            • Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 43 weeks, 3 days ago

                Development

                  Subcomponents

                    Structure Helper Panel