Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-119686

"Deploy/Save" button keeps enabled when there is no Form View selected for a step

    Details

      Description

      Steps to Reproduce

      1. Go to Applications Menu > App Builder > Objects
      2. Create an Object with Form and Table View
      3. Go to Applications Menu > App Builder > Apps > Workflow Powered
      4. Select to add a new Workflow App
      5. Select the Object, Form and Table View for the Start step
      6. Add a new step
      7. Go to the new step > click to add a new Form View > delete the previous Form View
      8. Click to "Deploy" the Workflow App

      Actual Result

      • "Deploy" button keeps enabled and a non-friendly message is displayed

      Expected Result

      • "Deploy" button should get disabled OR a user-friendly message should be displayed informing that 1 or more steps do not contain a Form View

      Reproduced In

      • DXP master: 2f00baef35f36c559aa0a2a480f9bfd4ec459615

        Attachments

          Activity

            People

            Assignee:
            rodrigo.cunha Rodrigo Cunha
            Reporter:
            rodrigo.cunha Rodrigo Cunha
            Participants of an Issue:
            Recent user:
            Enterprise Release HU
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              25 weeks, 5 days ago

                Packages

                Version Package
                7.3.X
                7.3.5 CE GA6
                7.3.10 DXP GA1
                Master