Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-119917

Unable to open a Data Provider after upgrade from 7.0.x to 7.3

    Details

      Description

       Description
      Unable to open a Data Provider after upgrade from 7.0.x to 7.3

       NOTES:
      Use Bundle of 7.0: liferay-ce-portal-tomcat-7.0-ga7 and MySQL 5.7 database to execute the tests.

       Steps to Reproduce

      1. Start up the 7.0 bundle
      2. Go to Content & Data > Forms;
      3. Click on kebab on top left and select "Data Provider";
      4. Fill data provider settings as follows:
        1. Name: Get Countries
        2. Description: Optional field
        3. URL: http://localhost:8080/api/jsonws/country/get-countries
        4. Displayed JSON Attribute: nameCurrentValue
        5. Stored JSON Attribute: List
        6. Username: [email protected]
        7. Password: test
      5. Save the data provider
      6. Shutdown the bundle and keep the database running
      7. Execute the necessary upgrades to migrate the database to the 7.3 bundle
      8. Start up a 7.3 bundle with the same database
      9. Go to Forms
      10. Click on Data Provider section and try to access the data provider created on 7.0

       Expected Result
      Data provider is accessible and is ready to be used on other forms

       Actual Result
      An error message is returned reporting that it is temporarily unavailable

       Reproduced In
      Portal master: 4a16aa246bd35999c481418074176cea3ddabca7
       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              cleyton.magalhaes Cleyton Magalhaes (Inactive)
              Reporter:
              bruno.oliveira Bruno Oliveira (Inactive)
              Participants of an Issue:
              Recent user:
              Enterprise Release HU
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 14 weeks ago

                  Packages

                  Version Package
                  7.3.5 CE GA6
                  7.3.10 DXP GA1
                  7.3.X
                  Master