Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-11997

Wiki Bug - Can't use parenthesis in article titles

    Details

      Description

      Reproduce Steps for Liferay Main Site
      1) Visit http://www.liferay.com/community/wiki/-/wiki/Main/Caching+%28disambiguation%29
      2) Click a link with parentheses (but not one of the "child pages")
      3) It refreshes your page or does something funny.
      4) click a child page
      5) it works

      The problem is that it doesn't work if the url doesn't have "+" signs stripped out

      Reproduce Steps for 5.2.3
      1) Make a wiki portlet
      2) Click "All Pages"
      3) Add a wiki page called "this is a test (this is a test)"
      4) Go to wiki frontpage
      5) add a link to [[this is a test (this is a test)]]
      6) It doesn't work. But it's not the same bug because it doesn't refresh all funny. also, I think it has to do with casing because if you create the page This is a test (this is a test), I think it works.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                support-lep@liferay.com SE Support
                Reporter:
                samuel.liu Sam Liu (Inactive)
                Participants of an Issue:
                Recent user:
                Esther Sanz
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  9 years, 15 weeks, 6 days ago

                  Packages

                  Version Package
                  --Sprint 12/11
                  6.1.0 CE RC1