Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-120663

Questions widget is unusable after clicking question label; TypeError appears

    Details

    • Fix Priority:
      4

      Description

      Note: This happens on both widget and content pages.

      Steps to reproduce:

      1. Add a Questions widget
      2. Add a new topic
      3. Add a question inside the topic
      4. View the question
      5. Click on the label above the question title (should be the question topic)

      Expected result:
      User is navigated to the home of the topic he clicked.

      Actual result:

      1UGMJ3samX.mp4

      Portlet error:

      Error:Could not load the page
      

      Typeerror in browser console:

      TypeError: Cannot read property 'id' of undefined
      

      The widget is unusable until the topic is removed.

      Reproduced on:
      Tomcat 9.0.37 + MySQL 5.7.
      Portal 7.3 DXP draft build 1 (https://release.liferay.com/1/userContent/liferay-release-tool/7310/20200908123826170/portal/)

        Attachments

        1. 1UGMJ3samX.mp4
          4.71 MB
        2. Capture.PNG
          Capture.PNG
          30 kB

          Issue Links

            Activity

              People

              Assignee:
              javier.dearcos Javier de Arcos Velilla
              Reporter:
              austin.chiang Austin Chiang
              Participants of an Issue:
              Recent user:
              Brian Wulbern
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 5 weeks, 2 days ago

                  Packages

                  Version Package
                  7.3.5 CE GA6
                  7.3.10 DXP GA1
                  Master