Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-123222

CKEditor Broken when Javascript loader is checked in

    Details

    • Branch Version/s:
      7.3.x, 7.2.x, 7.1.x, 7.0.x
    • Backported to Branch:
      Committed
    • Fix Priority:
      3

      Description

      Hi,

      I have successfully upgraded to Liferay 7.3.5-ga6 but there was a problem with the Javascript Loader (wich use require.js i suppose).

       

      When it's checked (global exposure) in the System Settings -> Foundation, the CkEditor is kind of broken.

      You can type your content and save but most of the features don't work like the "source code" mode.

      You can see a big JS error on the console :

       

      Steps to reproduce this :

      • Connect in admin mode or any other user that has sufficient rights
      • Go to System Settings -> Foundation -> Javascript Loader
      • Check Globale Exposure
      • Save
      • Go to your Site -> Content -> Create a new WebContent
      • Type some text in the content field and click on "Source" button

       

      I think it's related to the recent upgrade of the CKEditor embeded in Liferay.

      I Must use the loader for the JS code in our themes but i found a workaround :

      • Uncheck the Global Exposure of the Javascript Loader (CKEditor is fine after that)
      • Add RequireJs in every themes.

       

      Thank you in advance for your help.

      Regards.

      Yannick B.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              summer.zhang Summer Zhang
              Reporter:
              yannick.balla Yannick Balla
              Participants of an Issue:
              Recent user:
              Sophia Zhang
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                46 weeks, 3 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP97
                  7.0.X
                  7.1.10 DXP FP21
                  7.1.X
                  7.2.10 DXP FP10
                  7.2.10.4 DXP SP4
                  7.2.X
                  7.3.10 DXP FP1
                  7.3.10.1 DXP SP1
                  7.3.6 CE GA7
                  7.3.X
                  Master