PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-12353

Saving the values of the user's custom fields it loses addresses and phone numbers

    Details

    • Similar Issues:
      Show 5 results 

      Description

      Steps to reproduce the issue:

      1. Create custom fields for users.
      2. Edit any user
      3. Modify the addresses of the users (note that there are two buttons to add or delete more addresses)
      4. Click save. (Note that the two buttons are gone)
      5. Modify the custom fields of the users.
      6. Click save.
      7. If you check the addreesses you will find them empty.

      However, you won't find any problem by doing the following:

      1. Create custom fields for users.
      2. Edit any user
      3. Modify the addresses of the users (note that there are two buttons to add or delete more addresses)
      4. Click save. (Note that the two buttons are gone)
      5. Click Phone Numbers.
      6. Click again Addresses (you wll find that the two buttons are back)
      7. Modify the custom fields of the users.
      8. Click save.
      9. The address info is already there.

      Same happens with phone numbers.

        Issue Links

          Activity

          Hide
          Filippo added a comment -

          I tried to take the main.js file from the trunk but still does not work.

          Sometimes when i
          1. Enter a street address
          2. Save
          3. Enter a phone number
          4. Save

          At this point I lost the address inserted

          Show
          Filippo added a comment - I tried to take the main.js file from the trunk but still does not work. Sometimes when i 1. Enter a street address 2. Save 3. Enter a phone number 4. Save At this point I lost the address inserted
          Hide
          Nate Cavanaugh added a comment -

          Hi Filippo, I made some other changes regarding LPS-12486, which should fix what you mentioned (and has the fixed rev number).

          Thanks for letting us know about your issues,

          Show
          Nate Cavanaugh added a comment - Hi Filippo, I made some other changes regarding LPS-12486 , which should fix what you mentioned (and has the fixed rev number). Thanks for letting us know about your issues,
          Hide
          Viktor Palai added a comment -

          Hi Filippo,

          did you manage to fix this issue on 6.0.5 ?

          Dont you know when will be available version 6.1 ?

          Thanks

          Show
          Viktor Palai added a comment - Hi Filippo, did you manage to fix this issue on 6.0.5 ? Dont you know when will be available version 6.1 ? Thanks
          Hide
          James Falkner added a comment -

          add to 6.0.6 queue

          Show
          James Falkner added a comment - add to 6.0.6 queue
          Hide
          Brian Schupbach added a comment -

          Is there anyway I can get these changes? I just had an intern enter in the entire companies phone and addresses only to have them erased when people logged in and saved some custom questions we created in their profile. It would be great to get these back up for our directories and not have them erased...

          Thanks!

          Show
          Brian Schupbach added a comment - Is there anyway I can get these changes? I just had an intern enter in the entire companies phone and addresses only to have them erased when people logged in and saved some custom questions we created in their profile. It would be great to get these back up for our directories and not have them erased... Thanks!

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 25 weeks, 3 days ago

                Development

                  Structure Helper Panel