Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-124224

Could not save fragment configuration again when giving a wrong one at first

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 7.3.X, Master
    • Fix Version/s: Master
    • Labels:
      None

      Description

      Steps to reproduce:

      1. Add a collection
      2. Copy the Button frgament from Basic Components
        to created collection
      3. Edit the copied button frgament
      4. Go to Configuration
      5. Replace "dataType": "string", to "dataType": string",
      6. Publish the fragment
      7. Assert there's an error:Please provide a valid configuration for the fragment.
      8. Replace "dataType": string", to "dataType": "string",
      9. Assert frgament publishes successfully

      Actual result:
      There's an error:Please provide a valid configuration for the fragment. The workarond is to click back icon and edit the frgament, replace "dataType": string", to "dataType": "string", then the frgament publishes successfully.

      Expected result:
      Fragment publishes successfully.

        Attachments

          Activity

            People

            Assignee:
            lu.liu Lu Liu
            Reporter:
            lu.liu Lu Liu
            Participants of an Issue:
            Recent user:
            Lu Liu
            Engineering Assignee:
            Victor Galan
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              22 weeks, 4 days ago

                Packages

                Version Package
                Master