PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-12712

Searches made on Workflow Tasks do not always display the expected results.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.0.5 GA
    • Fix Version/s: --Sprint - SP, 6.1.0 CE RC1
    • Labels:
      None
    • Environment:
    • Branch Version/s:
      6.0.x
    • Backported to Branch:
      Committed
    • Similar Issues:
      Show 5 results 

      Description

      1. Navigate to "Control Panel -> Workflow Configurations"
      2. Configure all resources to "Single Approver" (Blogs Entry, Comment, Document Library, Message Boards Message, Web Content, Wiki Page)
      3. Add one of each resource (Blogs Entry, Comment, Document Library, Message Boards Message, Web Content, Wiki Page)
      4. Navigate to "Control Panel -> My Workflow Tasks"
      5. Click 'Advanced >>'
      6. Select 'Any' from the "Match [Any/All] of the following fields:" drop down.
      7. Make search queries for every "Type".

        • Many unexpected results will be returned. **
        • I've attached screen shots of what how it looks. **

      "Blogs Entry" ~ Returns both the "Document Library Document" and the "Blogs Entry".
      "Comments" ~ Returns nothing.
      "Message Boards Message" ~ Returns both the "Message Boards Message" and the "Comment".
      "Web Content" ~ Returns nothing.

      "Document Library" ~ Returns the expected results.
      "Wiki Page" ~ Returns the expected results.

        Activity

        Michael Hashimoto added a comment -

        This bug still exists in the following environments:

        Tomcat 6.0.29 + MySQL 5.0 + Firefox 3.6.12. Portal Revision 66325. Plugin Revision 66327. Trunk.
        Tomcat 6.0.29 + MySQL 5.0 + Firefox 3.6.12. Portal Revision 66325. Plugin Revision 66327. 6.0.x.

        Michael Hashimoto added a comment -

        Could no longer reproduce in these environments, so the bug is fixed in these environments:

        Tomcat 6.0.29 + MySQL 5.0 + Firefox 3.6.12. Portal Revision 67081. Plugin Revision 67081. Trunk.
        Tomcat 6.0.29 + MySQL 5.0 + Firefox 3.6.12. Portal Revision 67081. Plugin Revision 67081. 6.0.x.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              4 years, 21 weeks, 3 days ago

              Development

                Structure Helper Panel