Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-127203

Editor becames unresponsive on threads with multiple code snippets

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 7.3.5 CE GA6, Master
    • Fix Version/s: 7.4.13 DXP GA1, Master
    • Component/s: Questions
    • Labels:
      None

      Description

      When trying to reply to a Question thread whose previous messages contains several code snipets, the Editor becomes unresponsive, it blocks and the browser process shows a high CPU usage.

      To reproduce it

      1.- Create a Question that contains several (4-5) code snippets (some of them preferably long).

      2.- Create a couple of answers, and add a code snippet in at least one of them.

      3. try to write on the editor to create a fourth response, the Editor will block.

      (If you remove the `<pre>...</pre>` code snippets in the HTML loaded by the browser, the Editor won't show this problem.

      There's an online question that already shows this behaviour: https://liferay.dev/ask#/questions/portal/re-liferay-7-3-on-docker-with-elasticsearch-connection-refused

       

        Attachments

          Activity

            People

            Assignee:
            jamie.sammons Jamie Sammons
            Reporter:
            david.gomez David Gómez (Inactive)
            Participants of an Issue:
            Recent user:
            Sophia Zhang
            Engineering Assignee:
            Luis Miguel Barcos
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              39 weeks, 1 day ago

                Packages

                Version Package
                7.4.13 DXP GA1
                Master