Details

    Description

      Updating the client libraries and dependencies of the ES7 connector.

      Master,7.3.x

      1. Update client library from 7.9.0 to 7.14.0 and related dependencies (use highest minor with latest micro version available at the time)
      2. Update Sidecar Elasticsearch version to 7.14.10
      3. Adjust code (if needed)
      4. Update Elasticsearch versions used on CI
        1. ci:test:search-remote-minimum should be ran first with the current version to test eventual backward compatibility (newer client - older server)
      5. (Discuss) If we could introduce the necessary logic to extract sidecar into a versioned folder (elasticsearch7 -> elasticsearch-7.y.z). This would allow not to override data for existing test environments using Sidecar v7.9.0 and would also help to make sure installations are running with the new Sidecar version after installing a Fix Pack including these changes (DXP).

      7.1.x-7.2.x

      1. Update client library from 7.9.0 to 7.14.0 and related dependencies (use highest minor with latest micro version available at the time)
        1. This also updates the version of the Embedded ES server
      2. Adjust code (if needed)
      3. Update Elasticsearch versions used on CI
        1. ci:test:search-remote-minimum should be ran first with the current version to test eventual backward compatibility (newer client - older server)

      For detailed information including the compatible Elasticsearch 7 versions and required patch levels for released versions, see the Search Engine Compatibility Matrix: https://help.liferay.com/hc/en-us/articles/360016511651.

      Attachments

        Issue Links

          Activity

            People

              brian.chan Brian Chan
              tibor.lipusz Tibor Lipusz
              Bryan Engler Bryan Engler
              Kiyoshi Lee Kiyoshi Lee
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                Development End Date:
                Development Start Date:

                Packages

                  Version Package
                  7.3.10.5 DXP U5
                  7.4.13 DXP GA1
                  7.4.3.4 CE GA4