Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-131434

SLA stops to work when changing the Date & Time of the machine

    Details

    • Fix Priority:
      3

      Description

       Summary:
      SLA stops to work when changing the Date & Time of the machine

       Steps to Reproduce:

      1. Go to Applications Menu > Workflow > Process Builder > Configurations
      2. Assign Single Approver to Blogs Entry
      3. Go to Applications Menu > Workflow > Metrics > Single Approver
      4. Creates an SLA
      5. Change the Date & Time of your local machine (that has the Portal running) to a future date
      6. Change the Date & Time of your local machine back to automatic
      7. Go to Site Menu > Content & Data > Blogs
      8. Submit a Blog Entry
      9. Wait some minutes
      10. Go to Applications Menu > Workflow > Metrics > Single Approver

       Expected Result:
      Task is On Time

       Actual Result:
      Task is untracked and does not display the open SLA (even after reindex metrics indexes)

      Verified on master DXP: 03d7c8d68eb7d1074a41cb5a22d7938b62bdf6b9

        Attachments

          Activity

            People

            Assignee:
            team-workflow Product Team Workflow
            Reporter:
            rodrigo.cunha Rodrigo Cunha
            Participants of an Issue:
            Recent user:
            Rodrigo Cunha
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              10 weeks, 4 days ago

                Packages

                Version Package