Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-132334

Using an apostrophe "'" in a page title shows escaped HTML characters in the html's <title> tag

    Details

      Description

      Summary: Using an apostrophe "'" in a page title shows escaped HTML characters like "& #39;" in the html's <title> tag. If we navigate to the page url directly or we refresh the page it shows the wrong characters, however, if we navigate to the page from the Page tree links it shows the right characters.

      Steps to reproduce:
      1. Create a public page:
          Title: "There's a home" (with an apostrophe "'" character).
      2. Navigate to "http://localhost:8080/web/guest/there-s-a-home".

      Expected result: The html's <title> tag shows "There's a home - Liferay DXP".
      Actual result: The html's <title> tag shows "There& #39;s a home - Liferay DXP".

      Reproduced on: 7.3.x(8216c588e3d7d5ffb0819ecc815f1fd53207c8c7), master(ad820095bf57409341e820a33604db87e19c8451)

        Attachments

          Activity

            People

            Assignee:
            jorge.garcia Jorge García Jiménez
            Reporter:
            jorge.garcia Jorge García Jiménez
            Participants of an Issue:
            Recent user:
            Sophia Zhang
            Engineering Assignee:
            Jorge García Jiménez
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              17 weeks, 1 day ago

                Packages

                Version Package
                7.3.7 CE GA8
                7.3.X
                7.4.1 CE GA2 DXP 7,4
                Master