Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-133054

Account Roles in Roles Portlet does not count assignees.

Details

    • Bug
    • Status: Closed
    • Resolution: Duplicate
    • 7.4.0 CE GA1
    • None
    • None

    Description

      Despite assigning Users to an Account Role, navigating to the Account Roles tab in the Roles portlet shows the role to have "0 Assignees".

      Steps to reproduce:

      1. Create Account User A.
      2. Assign User A to Account X.
      3. Assign User A to Account Administrator under Account X.
      4. Navigate to Account Roles tab of Roles portlet.
      5. Results:
        1. Expected: Account Administrator role under Account X shows "1 Assignee"
        2. Actual: Account Administrator role under Account X shows "0 Assignees".

      The behavior is similar whether a user is assigned to an OOTB Account Role, or one created by the admin.

      Reference for screenshots: (1) After creating user Lee O. and assigning to Joe's Complete Auto Care; (2) Assigning user Lee O. the OOTB "Account Administrator" and user-created "Account Role X" roles; (3) Roles portlet still shows the count for both "Account Administrator" and "Account Role X" to have 0 Assignees.

      Attachments

        Issue Links

          Activity

            People

              support-lep@liferay.com SE Support
              leonard.bejosano Leonard Bejosano (Inactive)
              Kiyoshi Lee Kiyoshi Lee
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                1 year, 26 weeks, 4 days ago

                Packages

                  Version Package