Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-134199

Activating / Deactivating a Group discards its AssetCategories

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 7.3.5 CE GA6
    • Fix Version/s: None
    • Labels:
      None

      Description

      Setup:

      • Create or choose a vocabulary whose categories can be assigned to Sites
      • Create at least one category in this vocabulary
      • Create a new Site and assign a category to it

      Steps to reproduce:

      • Go to the Sites-Administration and disable the Site

      Expected Result:

      The Site is disabled but other parts of its configuration have not changed. What currently happens is, that the Site looses its assigned categories.

      I think the bug is caused by SiteAdminPortlet:684. In this line, the GroupService is called with a ServiceContext. As far as i understand, the Services use whatever categories they can find in the ServiceContext, to update the Group-Asset. Since the existing categories are never stored in the ServiceContext, the existing assignments will be removed. I think this would also apply to AssetTags.

        Attachments

          Activity

            People

            Assignee:
            support-lep@liferay.com SE Support
            Reporter:
            sebastian.glathe Sebastian Glathe
            Participants of an Issue:
            Recent user:
            Sebastian Glathe
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Days since last comment:
              24 weeks, 1 day ago

                Packages

                Version Package