Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-135023

Errors Accessibility on 7.1.x Styled Theme because of IE7 CSS rules starting with * in Font Awesome

Details

    Description

      Description: We have a client that is using this tool to verify the validity of their website (I explained more about this tool on LPS-133314) The tool seems to not like this CSS rules that starts with * made specially for fixing IE7 issues:
      *margin-right: .3em; 
      *line-height: 2em;
      *line-height: 1em;

      Steps:
      Start bundle and check for rules that start with "*margin" or "*line" in the following file /o/classic-theme/css/clay.css

      Actual: There are CSS files that contains rules that starts with *, these rules are fixes for IE7 that we don't support any more, and it should be removed as we have clients that complain about their accessibility tests failing cause of it. 

      Expected: There are no more rules starting with * in /o/classic-theme/css/clay.css file.

      Attachments

        Issue Links

          Activity

            People

              georgel.pop Georgel Vasile Pop
              georgel.pop Georgel Vasile Pop
              Kiyoshi Lee Kiyoshi Lee
              Georgel Vasile Pop Georgel Vasile Pop
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                1 year, 23 weeks, 1 day ago

                Packages

                  Version Package
                  7.1.10 DXP FP25
                  7.1.X
                  7.4.2 CE GA3 DXP 7,4
                  7.4.13 DXP GA1
                  Master