Details

    • Type: Impedibug
    • Status: Closed
    • Priority: Minor
    • Resolution: Completed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Forms
    • Labels:
      None
    • Sprint:
      Forms_7.4_18, Forms_7.4_19, Forms_7.4_20

      Description

      Description

      When the user sets a mask using an integer and changes the field type to decimal the input mask on decimal has inconsistent behavior.

      Steps to Reproduce

      1. Go to Content & Data >  Forms > Add new Form
      2. Add a Numeric field 
      3. Go to Advanced Tab
      4. Enable Input Mask
      5. Set an Input Mask
      6. Go back to the basic tab
      7. Select type as Decimal
      8. Go to the Advanced tab
      9. Enable Input Mask
      10. Set a mask
      11. Observe
      12. Publish the Form
      13. Go to published form
      14. Observe

      Expected Result

      The input mask must work correctly on Decimal field

      Actual Result

      The input mask is not working correctly on Decimal field

       Evidence:
      integerMaskErrorToDecimalMask.mp4

      Reproduced In master: 
      0a74e883abb9055af8c2ca25ba04bd4148514f23

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              carolina.barbosa Carolina Barbosa
              Reporter:
              diogo.santos Diogo Santos
              Recent user:
              Carolina Barbosa
              Participants of an Issue:
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Packages

                  Version Package