Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-140389

Questions appear to crash when there is no question

Details

    Description

      When access to a question that does not exist, Questions shows an alert message saying "Error loading question" and appears to crash.

      This could happen when we have saved the URL of a question that has been removed.

      Steps to reproduce

      1. Navigate to https://liferay.dev/ask/questions/development/modal-in-liferay

      Actual behavior

      Questions shows an alert message and appear to fail.

      Expected behavior

      Questions should shows a Not Found page or a more detailed error and do not look like it crash.

      Attachments

        Issue Links

          Activity

            People

              javier.gamarra Javier Gamarra (Inactive)
              luismiguel.barco Luis Miguel Barcos
              Kiyoshi Lee Kiyoshi Lee
              Luis Miguel Barcos Luis Miguel Barcos
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                51 weeks, 2 days ago

                Packages

                  Version Package
                  7.4.13 DXP GA1
                  7.4.3.4 CE GA4
                  7.4.3.5 CE GA5
                  7.4.13 DXP U1
                  Master