Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-140498

Fix compatibility between REST Builder 1.0.124 an Vulcan older versions

Details

    • Task
    • Status: Open
    • Minor
    • Resolution: Unresolved
    • None
    • None
    • REST Builder

    Description

      Due to a recent change on the REST Builder generation logic, where a new method ObjectMapperUtil.unsafeReadValue is used, the compatibility between REST Builder and Vulcan has been broken in REST Builder version 1.0.214.

       

      This compatibility issue affects also to 7.x.x branches where the backport of the ObjectMapperUtil new function is needed to fix the issue.

       

      This task should fix the 7.x.x branches with the latest version of REST Builder making the backport of the new function and try to change the logic in master to recover backward compatibility between Vulcan and REST Builder using a feature flag or similar mechanism to avoid using the new function if it does not exist in the Vulcan version that the project is using. 

      Attachments

        Issue Links

          Activity

            People

              alejandro.tardin Alejandro Tardín
              javier.dearcos Javier de Arcos Velilla
              Javier de Arcos Velilla Javier de Arcos Velilla
              Alejandro Tardín Alejandro Tardín
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:

                Packages

                  Version Package