Details

    • Type: Epic
    • Status: In Development
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Core Infrastructure
    • Labels:
    • Main Core Job:
      Orchestrate - Extend Platform Capabilities
    • Breaking Change:
      Yes

      Description

      Problem:

      Our core is over 20 years old and we have relied on many libraries that have not been updated in quite some time. These libraries are also used by parts of product that is no longer applicable for our customers (old deployment mechanisms, outdated practices). Since these libraries also are no longer maintained... we have been manually patching these libraries ourselves. This exposes us to many possible vulnerabilities because they are no longer as well tested as in the past.

      https://docs.google.com/spreadsheets/d/1CNdF-ONGvCl_dsltyemcouILLxE1zGBzhxujjn85akI/edit#gid=0

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              team-core-infra Product Team Core Infrastructure
              Reporter:
              shuyang.zhou Shuyang Zhou
              Recent user:
              Rafael Praxedes
              Participants of an Issue:
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:

                  Packages

                  Version Package