PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-14303

Asset Publisher RSS Feed does not validate in www.feedvalidator.org and cannot be used in some feed readers like facebook

    Details

    • Similar Issues:
      Show 5 results 

      Description

      I am using Liferay checkout from trunk on the 13th of November. When I Enable RSS Subscription, the feed button is available as expected and the feed is read correctly by mac safari browser. However, the feed generated is not accepted by Facebook as external source because of format problem. When tested for validation using www.feedvalidator.com, the error report is that the id for the entries are not valid ("id must be a full and valid URL"). The problem is that the id automatically generated for each entry in the feed does not have the full URL. E.g.

      instead of generating

      "<id>http://www.mydomain.com/web/guest/news/-/asset_publisher/4bZL/content/id/18916</id>"

      what is generated is

      "<id>/web/guest/university-news/-/asset_publisher/4bZL/content/id/18951</id>"

      This is not accept by some feed readers.

        Activity

        Hide
        Szymon Golebiewski added a comment -

        Pius,

        Can you check if it's still an issue with Liferay 6.1 CE GA1?

        Show
        Szymon Golebiewski added a comment - Pius, Can you check if it's still an issue with Liferay 6.1 CE GA1?
        Hide
        Pius Onobhayedo added a comment -

        Though I have not further tested on 6.1 GA1, I think that an earlier observation needs to be mentioned here. The malformed Feed URLs (id tags) seem to occur when I use mod-proxy-ajp between Apache and Liferay tomcat. The URL on the contrary is well formed when using mod_jk. Don't know if anyone else has similar experience with mod_proxy_ajp. Apologies for not having stated this earlier.

        Show
        Pius Onobhayedo added a comment - Though I have not further tested on 6.1 GA1, I think that an earlier observation needs to be mentioned here. The malformed Feed URLs (id tags) seem to occur when I use mod-proxy-ajp between Apache and Liferay tomcat. The URL on the contrary is well formed when using mod_jk. Don't know if anyone else has similar experience with mod_proxy_ajp. Apologies for not having stated this earlier.
        Hide
        Szymon Golebiewski added a comment -

        Pius,

        Well it looks like the problem is on mod-proxy-ajp side. Write about this problemon liferay forum - maybe other community users have solution for that.

        This issue will be closed.

        Show
        Szymon Golebiewski added a comment - Pius, Well it looks like the problem is on mod-proxy-ajp side. Write about this problemon liferay forum - maybe other community users have solution for that. This issue will be closed.
        Hide
        Michael Saechang added a comment -

        Closing as per Szymon's comment.

        Show
        Michael Saechang added a comment - Closing as per Szymon's comment.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              3 years, 17 weeks, 6 days ago

              Development

                Structure Helper Panel