PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-14671

When adding a document to the document library a file extension is required in the document title

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.0.5 GA, 6.0.X EE
    • Fix Version/s: 6.1.1 CE GA2
    • Labels:
      None
    • Environment:
      Liferay 6.0EE, Tomcat 6.x
    • Similar Issues:
      Show 5 results 

      Description

      To reproduce:
      Set portal-ext.properties as below:
      dl.file.extensions=.eps,.bmp,.css,.doc,.docx,.dot,.gif,.gz,.htm,.html,.jpg,.js,.lar,.mp3,.mp4,.odb,.odf,.odg,.odp,.ods,.odt,.pdf,.png,.ppt,.pptx,.rtf,.swf,.sxc,.sxi,.sxw,.tar,.tiff,.tgz,.txt,.vsd,.xls,.xlsx,.xml,.zip,.jrxml

      Then follow step below:
      1. Sign into Liferay and go to a document library.
      2. Select Add Document.
      3. Select Use the Classic Uploader method
      4. Select a file to upload
      5. Set the title to be the file name without the extension (for example if the file was joe.pdf, just use "joe" for the title)
      6. Submit
      7. A validation error should appear as in the attachment.

        Activity

        James Falkner added a comment -

        This issue is being addressed as part of the 100 PaperCuts program. Please see http://liferay.com/community/100-papercuts

        James Falkner added a comment -

        This issue was resolved as a side effect of the fix for LPS-14672.


          People

          • Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              4 years, 28 weeks, 3 days ago

              Development

                Structure Helper Panel