Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-146791

Add '--ignore-engines' flag to yarnInstall gradle task

    Details

    • Branch Version/s:
      7.3.x, 7.2.x, 7.1.x, 7.0.x
    • Backported to Branch:
      Committed
    • Sprint:
      S05E01 - Dark Souls

      Description

      If you are using node v10 (default on liferay 7.3.x), you may start to run into issues with npm/yarn install. sass recently released a new minor version that drops support for node less than v12. This error you will see is
      The engine "node" is incompatible with this module. Expected version ">=12.0.0"
      If you run into this issue, you can add a work around by using yarn resolutions and adding this to your package.json.
      "resolutions":

      { "sass": "1.49.0" }

      ,
      If you have any questions or issues, please let me know. We will try to update theme-tasks to account for this.

      By defaulting to ignore-engines, we are more closely aligned with npm and keeps us safe from accidental breaks like the one above.

        Attachments

          Activity

            People

            Assignee:
            bryce.osterhaus Bryce Osterhaus
            Reporter:
            bryce.osterhaus Bryce Osterhaus
            Engineering Assignee:
            SE Support
            Recent user:
            Rafaela Nascimento
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Packages

                Version Package
                7.0.X
                7.1.X
                7.2.X
                7.3.X
                Master