Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.0.5 GA, 6.1.0 CE RC1
    • Fix Version/s: 6.0.12 EE, 6.1.0 CE RC1
    • Component/s: WCM
    • Labels:
    • Branch Version/s:
      6.0.x
    • Backported to Branch:
      Committed
    • Similar Issues:
      Show 5 results 

      Description

      Deploying a portlet on trunk throws this exception:

      08:50:09,929 INFO [PluginPackageUtil:1080] Reading plugin package for TestPortlet
      08:50:09,931 ERROR [HotDeployUtil:112] com.liferay.portal.kernel.deploy.hot.HotDeployException: Error registering plugin
      s for TestPortlet
      com.liferay.portal.kernel.deploy.hot.HotDeployException: Error registering plugins for TestSpotlightPortlet
      at com.liferay.portal.kernel.deploy.hot.BaseHotDeployListener.throwHotDeployException(BaseHotDeployListener.java
      :45)
      at com.liferay.portal.deploy.hot.PluginPackageHotDeployListener.invokeDeploy(PluginPackageHotDeployListener.java
      :46)
      at com.liferay.portal.kernel.deploy.hot.HotDeployUtil._doFireDeployEvent(HotDeployUtil.java:109)
      at com.liferay.portal.kernel.deploy.hot.HotDeployUtil._fireDeployEvent(HotDeployUtil.java:183)
      at com.liferay.portal.kernel.deploy.hot.HotDeployUtil.fireDeployEvent(HotDeployUtil.java:38)
      at com.liferay.portal.kernel.servlet.PortletContextListener.doPortalInit(PortletContextListener.java:99)
      at com.liferay.portal.kernel.util.BasePortalLifecycle.portalInit(BasePortalLifecycle.java:42)
      at com.liferay.portal.kernel.util.PortalLifecycleUtil.register(PortalLifecycleUtil.java:61)
      at com.liferay.portal.kernel.util.PortalLifecycleUtil.register(PortalLifecycleUtil.java:51)
      at com.liferay.portal.kernel.util.BasePortalLifecycle.registerPortalLifecycle(BasePortalLifecycle.java:50)
      at com.liferay.portal.kernel.servlet.PortletContextListener.contextInitialized(PortletContextListener.java:55)
      at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4135)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4630)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:546)
      at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1041)
      at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:964)
      at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)
      at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1345)
      at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:303)
      at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
      at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1337)
      at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1601)
      at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1610)
      at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1590)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.NullPointerException
      at com.liferay.portal.plugin.PluginPackageUtil._readPluginPackageServletContext(PluginPackageUtil.java:1136)
      at com.liferay.portal.plugin.PluginPackageUtil.readPluginPackageServletContext(PluginPackageUtil.java:202)
      at com.liferay.portal.deploy.hot.PluginPackageHotDeployListener.doInvokeDeploy(PluginPackageHotDeployListener.ja
      va:84)
      at com.liferay.portal.deploy.hot.PluginPackageHotDeployListener.invokeDeploy(PluginPackageHotDeployListener.java
      :43)
      ... 25 more

        Activity

        Brian Chan added a comment -

        Hey Zsolt,

        The TCK test portlets don't end with "-portlet' and they deploy just fine?

        Matthew Petty added a comment -

        confirmed.
        build from trunk is also throwing this error for me when deploying portlets.

        Tammy Fong added a comment -

        PASSED Manual Testing

        1. Renamed plugin from Test-portlet-6.0.12.war to Testportlet.war
        2. Hot deploy the plugin

        Reproduced on:
        Tomcat 6.0.29 + MYSQL5.0. Firefox 4.0.1. 5.2.x Revision 77979.
        Tomcat 6.0.29 + MYSQL5.0. Firefox 4.0.1. 6.0.x Revision 77979.
        Tomcat 6.0.29 + MYSQL5.0. Firefox 4.0.1. 6.1.x Revision 77979.

        Fixed on:
        Tomcat 6.0.32 + MYSQL5.0. Firefox 4.0.1. 5.2.x Revision 82978.
        Tomcat 6.0.32 + MYSQL5.0. Firefox 4.0.1. 6.0.x Revision 82974.
        Tomcat 6.0.32 + MYSQL5.0. Firefox 4.0.1. 6.1.x Revision 82974.

        Results on Affected:
        Deploying the file generates a HotDeployUtil:112 error exception. Portlet is functioning.

        Results on Fixed:
        Deploying the file generates the following warning message: Plugin package on context testportlet cannot be tracked... Portlet is functioning.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              4 years, 4 weeks, 5 days ago

              Development

                Structure Helper Panel