Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.1.0 CE RC1
    • Fix Version/s: --Sprint 12/11, 6.1.0 CE RC1
    • Component/s: UI Infrastructure
    • Labels:
      None
    • Environment:
      google chrome, LR r.73500
    • Branch Version/s:
      6.0.x
    • Similar Issues:
      Show 5 results 

      Description

      Hi, there is a problem in ckeditor.jsp in function initCkArea() there is this statement :

      ckEditor.setData(parent.<%= HtmlUtil.escape(initMethod) %>());

      but "parent" is always null in google chrome, therefore the initMethod is never called...

      I think it has something to do with the fact, that this javascript is within an iFrame and some browsers have problem with that.

      Btw I don't know why, but if I put ckeditor in Alloy panel (via jsp tag), it is rendered twice: first time without the panel, second time with the panel... It is very easily reproducable, just do

      <aui:panel collapsible='<%= true %>' label="label.details" id="details" >
      <liferay-ui:input-editor width="700" height="400" initMethod='<%= renderResponse.getNamespace() + "initEditor" %>'/>
      </aui:panel>

      and you should see the result. Regards

        Activity

        Jakub Liska added a comment -

        It's a typical issue with google chrome, it sometimes doesn't allow to call "parent" function. But in LR ckeditor it has never worked for me since chrome 4 up to chrome 9

        Jakub Liska added a comment -

        Anyways, this is a quite important issue, because if the error is thrown (because of null parent), the execution stops and the event handling (callback) isn't initialized ...

        Kory Hoopes added a comment -

        This issue was resolved with ticket LPS-16262 where the iframe wrapping the editor was removed.


          People

          • Assignee:
            Kory Hoopes
            Reporter:
            Jakub Liska
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              3 years, 48 weeks, 5 days ago

              Development

                Structure Helper Panel