PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-15677

Asset Publisher portlet does not display web content, When the content publish again.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 5.2.X EE, 6.0.5 GA, 6.0.12 EE, 6.1.0 CE RC1
    • Fix Version/s: --Sprint 12/11, 6.1.0 CE RC1
    • Labels:
    • Environment:
      Tomcat 6 + MySQL 5. 6.1.x Revision 74678.
      Tomcat 6 + MySQL 5. 6.0.x Revision 74642.
      Tomcat 6 + MySQL 5. 5.2.x Revision 74676.
    • Liferay Contributor's Agreement:
      Accept
    • Similar Issues:
      Show 4 results 

      Description

      Asset Publisher portlet does not display web content, When the content publish again.

      Steps to reproduced :

      1. Start liferay and login.
      2. Add a page and add Asset Publisher portlet.
      3. Then click Add New button add a web content.
      4. Then go to Control Panel >> Web Content expire the content.
      5. Now you can not see the web content in Asset Publisher portlet.
      6. Go to Control Panel >> Web Content edit the content and publish button.
      7. Then back to liferay check Asset Publisher portlet.

        Activity

        Michael Saechang added a comment -

        This issue may not be a bug. This may be the expected behavior of the portal. When expiring the article the asset publisher probably removes it, so even after publishing it again, it is no longer in the asset publisher. Will keep the ticket open and have an engineer decide.

        Henri Koskenranta added a comment -

        I can confirm this too. You don't even need to edit the content, just expire and re-publish and it's not showing in the asset publisher.

        Asset publishers are there to show content based on filters and selections. They show content dynamically. Whether an article was expired and is now published again should have no meaning for asset publisher. It should show an article if it matches the filters, a publisher article is a publisher article, no matter it's history.

        Tagnaouti Boubker added a comment -

        "This issue is being addressed as part of the 100 PaperCuts program. Please see http://liferay.com/community/100-papercut"

        I can confirm this too... this behavior still persist on the trunk version.

        Tagnaouti Boubker added a comment -

        Draft asset entry object seems to be never created :

        boolean addDraftAssetEntry = false;

        if (!article.isApproved() &&
        (article.getVersion() != JournalArticleConstants.DEFAULT_VERSION)) {

        int approvedArticlesCount =
        journalArticlePersistence.countByG_A_ST(
        article.getGroupId(), article.getArticleId(),
        WorkflowConstants.STATUS_APPROVED);

        if (approvedArticlesCount > 0)

        { addDraftAssetEntry = true; }

        }

        Tagnaouti Boubker added a comment -

        Here is a patch to solve this issue.

        Hi Mark can you try this patch and let us know if it fixes the issue for you?

        Thank to click on the link "Accept Contribution" if it's ok!

        Mark Jin added a comment -

        Hi! Tagnaouti I tested the problem in 61x(76373). It fixed.

        James Falkner added a comment -

        Hi Mark,

        Please click the "Accept Contribution" button at the top to ensure this fix is incorporated in a future version of Liferay. Thanks!

        Peter Shin added a comment -

        Thank you for your contribution.

        Reviewed the patch and fixed it in a different way. Fix is to sync the AssetEntry expiration date with JournalArticle expiration date in JournalArticleLocalServiceImpl#updateStatus.

        Mark Jin added a comment -

        PASSED Manual Testing following steps in description.

        Reproduced on:
        Tomcat 6.0 + MySQL 5. Firefox 5.0. 6.0.12 EE.
        Tomcat 6.0 + MySQL 5. Firefox 5.0. 6.1.x Revision 86357.

        Fixed on:
        Tomcat 6.0 + MySQL 5. Firefox 5.0. 6.1.x Revision 86401.


          People

          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              4 years, 4 weeks, 4 days ago

              Development

                Structure Helper Panel