Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 6.0.6 GA
    • Fix Version/s: 6.0.6 GA
    • Labels:
      None
    • Environment:
      LF 6.0.6 CE, Glassfish 3.1, Mac OS X 10.6.7
    • Similar Issues:
      Show 5 results 

      Description

      Hello,

      I have deployed a LF 6.0.6 war distribution on a Glassfish 3.1 server. Everything works fine except that I can't get international (french éàèç or german äöü) characters to display correctly.

      When looking at the page's source code, I can see the <meta content="text/html; charset=UTF-8" http-equi="content-type"/>

      The http listeners in GF 3.1 are set to UTF-8. MySQL is set to UTF-8 and the jdbc connection string has the encoding set to UTF-8.

      The problem is not limited to labels coming from MySQL (like page names) but also labels coming from the language properties files.

      Also, when in the Control Panel - Manage Pages, I can see the special characters correctly displayed in the pages tree view, but not in the detailed view on the right side.

      I also noticed that the GF bundle only contains a GF 3.0.1.

      Is there a problem with GF 3.1 and is there a solution to make the special characters display correctly?

        Activity

        Fernando Correia added a comment -

        I have the exact same issue as reported (in Portuguese) at http://www.liferay.com/pt/community/forums/-/message_boards/message/10005372

        Alex Weirig added a comment -

        Hello,

        I think you can close this ticket. 6.0.6 is kind of old and I haven't tested with 6.1.0.

        Alex

        Yordan Nalbantov added a comment -

        It's actually a Glassfish issue. See http://java.net/jira/browse/GLASSFISH-18516
        Liferay 6.1.0 CE B4 with GF 3.1.1 should work just fine.

        Alex Weirig added a comment -

        Hello,

        I think we should close this ticket.


          People

          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 19 weeks, 6 days ago

              Development

                Structure Helper Panel