Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Duplicate
    • Affects Version/s: 6.1.0 CE RC1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Tomcat 7.0.10 + MySQL 5.1.56. Firefox 3.6.16. 6.1.x Revision 76900.
    • Liferay Contributor's Agreement:
      Accept
    • Similar Issues:
      Show 5 results 

      Description

      Steps to reproduce:

      1) Add Document Library and Document Library Display to the same page.
      2) Add a Document.
      3) Display the document uploaded in step 2 in Document Library Display.
      4) Delete the document in Document Library.

      Tomcat:

      09:09:03,811 ERROR [IncludeTag:404] Current URL /web/guest/home/-/document_library generates exception: null
      09:09:03,815 ERROR [IncludeTag:154] java.lang.NullPointerException
      at org.apache.jsp.html.portlet.document_005flibrary.view_005ffile_005fentry_jsp._jspService(view_005ffile_005fentry_jsp.java:1048)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
      at com.liferay.portal.kernel.servlet.DirectRequestDispatcher.include(DirectRequestDispatcher.java:45)
      at com.liferay.taglib.util.IncludeTag.include(IncludeTag.java:314)
      at com.liferay.taglib.util.IncludeTag._doInclude(IncludeTag.java:396)
      at com.liferay.taglib.util.IncludeTag.doEndTag(IncludeTag.java:91)
      at org.apache.jsp.html.common.themes.portlet_jsp._jspService(portlet_jsp.java:4174)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:417)
      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:391)
      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:304)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:67)
      at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:108)
      at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilter.doFilter(InvokerFilter.java:86)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)

        Issue Links

          Activity

          Tomáš Polešovský added a comment -

          This issue is currently being addressed in Sprint 4 of the 100 PaperCuts program. Please see http://liferay.com/community/100-papercuts

          Tomáš Polešovský added a comment -

          Fix of the portal-web/docroot/html/portlet/document_library/view_file_entry.jsp.

          It's fixed the same way as LPS-16254, i.e. if fileEntry is not found (==null) then rendering default view.jsp.

          Ryan Wan added a comment - - edited

          This issue is currently unable to reproduce at revision 84825, I'll try to reproduce after few revision growth.

          Samuel Kong added a comment -

          Closing based on Ryan's comment


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                4 years, 7 weeks, 1 day ago

                Development

                  Subcomponents

                    Structure Helper Panel