Details

    • Branch Version/s:
      6.0.x
    • Liferay Contributor's Agreement:
      Accept
    • Similar Issues:
      Show 5 results 

      Description

      I made three categories and some articles which are all belonging to some categories and tried to switch around. It seems like I can't switch the category with category-navigation while having an article open. But it is possible in the article itself.

      Please see the video I made.

      Is this the desired behaviour?

      http://www.youtube.com/watch?v=ROLrN1XYA_I

        Issue Links

          Activity

          Hide
          Juan G added a comment -

          This issue is a backlog candidate for the 100 PaperCuts program. Please consider participating! See http://liferay.com/community/100-papercuts

          Show
          Juan G added a comment - This issue is a backlog candidate for the 100 PaperCuts program. Please consider participating! See http://liferay.com/community/100-papercuts
          Hide
          Juan G added a comment -

          This issue is currently being addressed in Sprint 4 of the 100 PaperCuts program. Please see http://liferay.com/community/100-papercuts

          Show
          Juan G added a comment - This issue is currently being addressed in Sprint 4 of the 100 PaperCuts program. Please see http://liferay.com/community/100-papercuts
          Hide
          Juan G added a comment -

          Not reproducible in Tomcat 6.0.29, HSQL, Ubuntu revision 77864.

          Hi Marco,

          I've been testing this and seems to be working ok.

          I've created 3 categories, and then three wiki pages, each page with each category.

          After that I've added a categories navigation, and then selected each category, then in wiki portlet displayed the pages ok (one page for each category). Then I chose a wiki page. After opening that page I selected another category, then selected a wiki with other categories and was opening ok.

          Can you confirm my test is same as yours? If so, could you try to test in latest trunk version if it's already resolved?

          Thanks very much

          Show
          Juan G added a comment - Not reproducible in Tomcat 6.0.29, HSQL, Ubuntu revision 77864. Hi Marco, I've been testing this and seems to be working ok. I've created 3 categories, and then three wiki pages, each page with each category. After that I've added a categories navigation, and then selected each category, then in wiki portlet displayed the pages ok (one page for each category). Then I chose a wiki page. After opening that page I selected another category, then selected a wiki with other categories and was opening ok. Can you confirm my test is same as yours? If so, could you try to test in latest trunk version if it's already resolved? Thanks very much
          Hide
          Marco Peroverde added a comment -

          Hi Juan,

          just updated the source and did a fresh ant all.
          I still can't switch categories after openeing an article from a categorylist.
          Did you create your wiki page with the "wiki" template?
          Are you switching the categories exclusively with the categorynavigation on the right side of the screen (default)?

          I found out, that applying your patch from http://issues.liferay.com/browse/LPS-11859 helps.

          Show
          Marco Peroverde added a comment - Hi Juan, just updated the source and did a fresh ant all. I still can't switch categories after openeing an article from a categorylist. Did you create your wiki page with the "wiki" template? Are you switching the categories exclusively with the categorynavigation on the right side of the screen (default)? I found out, that applying your patch from http://issues.liferay.com/browse/LPS-11859 helps.
          Hide
          Juan G added a comment -

          Ok Marco can you confirm if LPS-11859 solves the issue? That's why I can't reproduce it, although LPS-11859 isn't commited to trunk, because I've already have that patch applied in my local sources.

          Show
          Juan G added a comment - Ok Marco can you confirm if LPS-11859 solves the issue? That's why I can't reproduce it, although LPS-11859 isn't commited to trunk, because I've already have that patch applied in my local sources.
          Hide
          Marco Peroverde added a comment -

          I can confirm that your patch does the job.
          Just reapplied it and wiki is now working.

          Show
          Marco Peroverde added a comment - I can confirm that your patch does the job. Just reapplied it and wiki is now working.
          Hide
          Juan G added a comment -

          Already solved with this LPS patch:

          http://issues.liferay.com/browse/LPS-11859

          Please Mauro, can you click in "Accept solution" for this issue to be managed by Liferay staff?

          Show
          Juan G added a comment - Already solved with this LPS patch: http://issues.liferay.com/browse/LPS-11859 Please Mauro, can you click in "Accept solution" for this issue to be managed by Liferay staff?
          Hide
          Peter Shin added a comment -
          Show
          Peter Shin added a comment - See http://issues.liferay.com/browse/LPS-14964

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 44 weeks ago

                Development

                  Structure Helper Panel