PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-16959

Asset publisher - Web content with revision greater than 1.0 not shown in manual selection

    Details

    • Similar Issues:
      Show 4 results 

      Description

      When you select (in example) a web content with a revision greater than 1.0 you can select it, but it does not appear in asset publisher, but another one with 1.0 revision is shown correctly.

        Activity

        Hide
        Ryan Wan added a comment -

        Hi Joseph,

        Thank you for the report. I have test this in 6.0.6 GA but I cannot reproduce the issue that you having.
        Please ensure that you are running Liferay in a clean enviroment to avoid other issues involving in this.
        If you are still having this problem, please update this ticket with more information on how you encountered this issue.

        Thanks

        Show
        Ryan Wan added a comment - Hi Joseph, Thank you for the report. I have test this in 6.0.6 GA but I cannot reproduce the issue that you having. Please ensure that you are running Liferay in a clean enviroment to avoid other issues involving in this. If you are still having this problem, please update this ticket with more information on how you encountered this issue. Thanks
        Hide
        Joseph M. Sentis added a comment -

        Hello.

        I tried to reproduce the behaviour in 2 different machines with success (another Solaris 10 + Mysql and Ubuntu 10.11 + Hipersonic ) tested with Firefox 4.0.1. I did these steps:

        -Create an asset publisher in one page.
        -In another tab from control panel create a web content (in one community in example Liferay).
        -Configure the asset publisher (Asset selection: manual) , click "select existing" button choose the web content created previously -> OK
        -Then edit the web content and publish it (rev 1.1), in the asset publisher you will see it.
        -Now configure asset publisher again (Asset selection manual), delete from the list the web content and try to select it again with "select existing" button. It gives ok message in green but no web content is shown -> KO

        Show
        Joseph M. Sentis added a comment - Hello. I tried to reproduce the behaviour in 2 different machines with success (another Solaris 10 + Mysql and Ubuntu 10.11 + Hipersonic ) tested with Firefox 4.0.1. I did these steps: -Create an asset publisher in one page. -In another tab from control panel create a web content (in one community in example Liferay). -Configure the asset publisher (Asset selection: manual) , click "select existing" button choose the web content created previously -> OK -Then edit the web content and publish it (rev 1.1), in the asset publisher you will see it. -Now configure asset publisher again (Asset selection manual), delete from the list the web content and try to select it again with "select existing" button. It gives ok message in green but no web content is shown -> KO
        Hide
        Ryan Wan added a comment -

        Hey Joseph,

        Thanks for response so quickly, but I was still unable to verify the issue you have described in 6.0.6 GA(due to another issue).
        So I have test this in trunk, and I was able to select Web Content successfully by following your steps. Which means, if this is an actual existing bug in 6.0.6 GA, then it's fixed in trunk.

        Show
        Ryan Wan added a comment - Hey Joseph, Thanks for response so quickly, but I was still unable to verify the issue you have described in 6.0.6 GA(due to another issue). So I have test this in trunk, and I was able to select Web Content successfully by following your steps. Which means, if this is an actual existing bug in 6.0.6 GA, then it's fixed in trunk.
        Hide
        Joseph M. Sentis added a comment -

        Hello Ryan,

        Only one pair of questions then. Trunk will be released as 6.0.7 GA? Can i catch trunk and make a portal-ext to update our 6.0.6 version?

        Thanks for your time.

        Regards.

        Show
        Joseph M. Sentis added a comment - Hello Ryan, Only one pair of questions then. Trunk will be released as 6.0.7 GA? Can i catch trunk and make a portal-ext to update our 6.0.6 version? Thanks for your time. Regards.
        Hide
        Marc Piparo added a comment -

        Has anyone been able to apply this patch to 6.0.6? I've confirmed that selection of assets with any revisions are indeed added to the "asset-entry-xml", however apparently not being stored in the portlet preferences. For strange reason on preferences retrieval, these assets are missing! Though assets without any revisions are stored and retrieved ok. thanks!

        Show
        Marc Piparo added a comment - Has anyone been able to apply this patch to 6.0.6? I've confirmed that selection of assets with any revisions are indeed added to the "asset-entry-xml", however apparently not being stored in the portlet preferences. For strange reason on preferences retrieval, these assets are missing! Though assets without any revisions are stored and retrieved ok. thanks!
        Hide
        Gabriel Landon added a comment -

        This looks like a duplicate of #LPS-14405

        Show
        Gabriel Landon added a comment - This looks like a duplicate of # LPS-14405

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              3 years, 20 weeks, 5 days ago

              Development

                Structure Helper Panel