PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-17416

portletSession attributes not correct across organizations when doing interportlet

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.0.6 GA
    • Fix Version/s: 6.1.30 EE GA3, 6.2.0 CE M2
    • Component/s: Legacy
    • Labels:
      None
    • Similar Issues:
      Show 5 results 

      Description

      on event 'catch' side: when portletSession attribute is set within method @ProcessEvent, there is inconsistency in session attribute value when 'sender' side comes from different organizations

        Activity

        Mika Koivisto added a comment -

        Can you provide a little bit more steps to reproduce the issue?

        Jack Bakker added a comment -

        Hi Mika, been 2 years since I experienced this in CE v6.0.5 ; I should have provided better steps at the time. Thanks.

        Mika Koivisto added a comment -

        Yeah, it's been a while. I'm just going through all the old issues still in open state to see if they can be still reproduced.

        The thing I don't understand is how the organization could affect but I'll see if there's anything funky about the portlet session with events.

        Mika Koivisto added a comment -

        Okay so I test the use of portlet session with events and it works according to the portlet spec.

        I've got portlets A and B. Portlet A produces a event X on processAction and sets a portlet session attribute Y. Both portlets A and B also consumes event X. As they process the the event X they also inspect the value of session attribute Y. In portlet A the session attribute Y is set where as in portlet B it is not. Now if we set the attribute with application scope and retrieve it from application scope on both portlets then they will see it only if both of the portles are in the same WAR otherwise only portlet A will see it.


          People

          • Assignee:
            Mika Koivisto
            Reporter:
            Jack Bakker
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 6 weeks ago

              Development

                Structure Helper Panel