PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-17421

Upgrade from 5.2 SP4 to 6.0 EE will cause MySQLIntegrityConstraintViolationException

    Details

    • Branch Version/s:
      6.0.x
    • Fix Priority:
      3
    • Similar Issues:
      Show 4 results 

      Description

      Attemptiong to upgrade a database created in 5.2 SP4 to 6.0 EE the following error occurs:

      00:40:25,572 ERROR [MainServlet:202]
      com.liferay.portal.kernel.events.ActionException:
      com.liferay.portal.kernel.upgrade.UpgradeException:
      com.liferay.portal.kernel.upgrade.UpgradeException:
      com.mysql.jdbc.exceptions.MySQLIntegrityConstraintViolationException:
      Duplicate entry '10155-24820-239107' for key 1
      com.liferay.portal.kernel.events.ActionException:
      com.liferay.portal.kernel.upgrade.UpgradeException:
      com.liferay.portal.kernel.upgrade.UpgradeException:
      com.mysql.jdbc.exceptions.MySQLIntegrityConstraintViolationException:
      Duplicate entry '10155-24820-239107' for key 1

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            EE Support
            Reporter:
            Eric Min (Inactive)
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Days since last comment:
              3 years, 49 weeks, 5 days ago

              Development

                Structure Helper Panel