Details

    • Similar Issues:
      Show 5 results 

      Description

      Case 1
      1. Control Panel> Web Content
      2. Add [Basic Web Content]

      Results: there are fields without headings, and values in these fields will not be saved (DefaultWC.png).

      Case 2:
      1. Control Panel> Web Content: Structure
      2. Add Structure xxx with Title, Body
      3. Add Web Content selecting that Structure
      4. Next to Structure: xxx, click [Edit]

      Results: All fields will have the message [This field is required] though the "required" option isn't checked (Structure.png). Web Content can still be published even if these fields are not filled.

      In edit mode, the Form Controls, Application Fields etc are not usable. It is difficult to edit structure.

      1. WCexception.txt
        2 kB
        Tammy Fong
      1. DefaultWC.png
        175 kB
      2. Screen shot 2011-07-07 at 12.27.24.png
        537 kB
      3. Screen shot 2011-07-07 at 12.29.28.png
        350 kB
      4. Screen shot 2011-07-07 at 12.46.15.png
        110 kB
      5. Screen shot 2011-08-05 at 6.13.32 PM.png
        164 kB
      6. Structure.png
        223 kB

        Issue Links

          Activity

          Hide
          Alex Weirig added a comment -

          A possible enhanced graphical presentation of the same screen.
          Icons and fields have been moved, redundant options removed, margins reduced

          Show
          Alex Weirig added a comment - A possible enhanced graphical presentation of the same screen. Icons and fields have been moved, redundant options removed, margins reduced
          Hide
          Ivica Cardic added a comment -

          Web Content can be published and saved. There is no message [This field is required]. Regarding to editing structure fields this is connected to LPS-17773. Formatting of the fields in edit mode is ok.

          Show
          Ivica Cardic added a comment - Web Content can be published and saved. There is no message [This field is required] . Regarding to editing structure fields this is connected to LPS-17773 . Formatting of the fields in edit mode is ok.
          Hide
          Ivica Cardic added a comment -

          Maybe weird issue is that there is no messages [This field is required] but when you click Edit Options of the field, Required is checked

          Show
          Ivica Cardic added a comment - Maybe weird issue is that there is no messages [This field is required] but when you click Edit Options of the field, Required is checked
          Hide
          Igor Bešlić added a comment -

          I confirm, after fixing http://issues.liferay.com/browse/LPS-17773 case 2 is OK - but as Ivica said despite fields are required and it is visible in edit options they are checked to be required, there is no warrning message below field in edit screen.

          Show
          Igor Bešlić added a comment - I confirm, after fixing http://issues.liferay.com/browse/LPS-17773 case 2 is OK - but as Ivica said despite fields are required and it is visible in edit options they are checked to be required, there is no warrning message below field in edit screen.
          Hide
          Tammy Fong added a comment -

          This issue is no longer reproduced on 6.1.x Revision 86591.
          The error described by Ivica has been created on LPS-19763.

          Show
          Tammy Fong added a comment - This issue is no longer reproduced on 6.1.x Revision 86591. The error described by Ivica has been created on LPS-19763 .

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 41 weeks, 5 days ago

                Development

                  Structure Helper Panel