Details

    • Similar Issues:
      Show 5 results 

      Description

      1. Control Panel> Server: Portal Instances
      2. Click [Add]

      User is unable to save nor cancel the instance and sees the following exception:

      08:43:58,647 ERROR [IncludeTag:410] Current URL /group/control_panel/manage?p_p_id=135&p_p_lifecycle=0&p_p_state=maximized&p_p_mode=view&_135_struts_action=%2Fadmin_instances%2Fedit_instance&_135_redirect=http%3A%2F%2Flocalhost%3A8080%2Fgroup%2Fcontrol_panel%2Fmanage%3Fp_p_id%3D135%26p_p_lifecycle%3D0%26p_p_state%3Dmaximized%26p_p_mode%3Dview generates exception: An exception occurred processing JSP page /html/portlet/admin/edit_instance.jsp at line 99

      96:
      97: <aui:input name="maxUsers" />
      98:
      99: <aui:input disabled="<%= company2.getCompanyId() == PortalInstances.getDefaultCompanyId() %>" name="active" type="checkbox" value="<%= (company2 != null) ? company2.isActive() : true %>" />
      100: </aui:fieldset>
      101:
      102: <aui:button-row>

      Stacktrace:
      08:43:58,649 ERROR [IncludeTag:154] java.lang.NullPointerException
      at org.apache.jsp.html.portlet.admin.edit_005finstance_jsp._jspService(edit_005finstance_jsp.java:1331)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:386)
      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:67)
      at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:108)
      at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilter.doFilter(InvokerFilter.java:86)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:646)
      at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:551)
      at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:488)
      at com.liferay.taglib.util.IncludeTag.include(IncludeTag.java:317)
      at com.liferay.taglib.util.IncludeTag._doInclude(IncludeTag.java:402)
      at com.liferay.taglib.util.IncludeTag.doEndTag(IncludeTag.java:92)

        Issue Links

          Activity

          Alex Weirig created issue -
          Tammy Fong made changes -
          Field Original Value New Value
          Assignee SE Support [ support-lep@liferay.com ] Tammy Fong [ tammy.fong ]
          Tammy Fong added a comment -

          Hi Alex, Thank you for the report. I am able to reproduce this issue on 6.1.x revision 84585. I will update this ticket to reflect the issue. Thanks

          Tammy Fong made changes -
          Assignee Tammy Fong [ tammy.fong ] SE Support [ support-lep@liferay.com ]
          Attachment instances.png [ 33040 ]
          Environment Nightly build 2011-07-03, Tomcat, MySQL Tomcat 6.0.32 + MYSQL5.0. 6.1.x Revision 84585.
          Priority Critical [ 2 ] Major [ 3 ]
          Description When trying to create a new portal instance, I get a NPE in the console:

          08:43:58,647 ERROR [IncludeTag:410] Current URL /group/control_panel/manage?p_p_id=135&p_p_lifecycle=0&p_p_state=maximized&p_p_mode=view&_135_struts_action=%2Fadmin_instances%2Fedit_instance&_135_redirect=http%3A%2F%2Flocalhost%3A8080%2Fgroup%2Fcontrol_panel%2Fmanage%3Fp_p_id%3D135%26p_p_lifecycle%3D0%26p_p_state%3Dmaximized%26p_p_mode%3Dview generates exception: An exception occurred processing JSP page /html/portlet/admin/edit_instance.jsp at line 99

          96:
          97: <aui:input name="maxUsers" />
          98:
          99: <aui:input disabled="<%= company2.getCompanyId() == PortalInstances.getDefaultCompanyId() %>" name="active" type="checkbox" value="<%= (company2 != null) ? company2.isActive() : true %>" />
          100: </aui:fieldset>
          101:
          102: <aui:button-row>


          Stacktrace:
          08:43:58,649 ERROR [IncludeTag:154] java.lang.NullPointerException
          at org.apache.jsp.html.portlet.admin.edit_005finstance_jsp._jspService(edit_005finstance_jsp.java:1331)
          at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
          at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:386)
          at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
          at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:67)
          at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:108)
          at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilter.doFilter(InvokerFilter.java:86)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:646)
          at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:551)
          at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:488)
          at com.liferay.taglib.util.IncludeTag.include(IncludeTag.java:317)
          at com.liferay.taglib.util.IncludeTag._doInclude(IncludeTag.java:402)
          at com.liferay.taglib.util.IncludeTag.doEndTag(IncludeTag.java:92)

          Also, there is no [ADD] button shown on the page.
          1. Control Panel> Server: Portal Instances
          2. Click [Add]

          User is unable to save nor cancel the instance and sees the following exception:

          08:43:58,647 ERROR [IncludeTag:410] Current URL /group/control_panel/manage?p_p_id=135&p_p_lifecycle=0&p_p_state=maximized&p_p_mode=view&_135_struts_action=%2Fadmin_instances%2Fedit_instance&_135_redirect=http%3A%2F%2Flocalhost%3A8080%2Fgroup%2Fcontrol_panel%2Fmanage%3Fp_p_id%3D135%26p_p_lifecycle%3D0%26p_p_state%3Dmaximized%26p_p_mode%3Dview generates exception: An exception occurred processing JSP page /html/portlet/admin/edit_instance.jsp at line 99

          96:
          97: <aui:input name="maxUsers" />
          98:
          99: <aui:input disabled="<%= company2.getCompanyId() == PortalInstances.getDefaultCompanyId() %>" name="active" type="checkbox" value="<%= (company2 != null) ? company2.isActive() : true %>" />
          100: </aui:fieldset>
          101:
          102: <aui:button-row>


          Stacktrace:
          08:43:58,649 ERROR [IncludeTag:154] java.lang.NullPointerException
          at org.apache.jsp.html.portlet.admin.edit_005finstance_jsp._jspService(edit_005finstance_jsp.java:1331)
          at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
          at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:386)
          at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
          at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:67)
          at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:108)
          at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilter.doFilter(InvokerFilter.java:86)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:646)
          at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:551)
          at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:488)
          at com.liferay.taglib.util.IncludeTag.include(IncludeTag.java:317)
          at com.liferay.taglib.util.IncludeTag._doInclude(IncludeTag.java:402)
          at com.liferay.taglib.util.IncludeTag.doEndTag(IncludeTag.java:92)
          Component/s High Availability / Clustering [ 10253 ]
          Component/s Management and Monitoring [ 11134 ]
          Tammy Fong added a comment -

          A record of this issue exist on LPS-18549. To avoid confusion of duplicate issues, I will close this ticket and use the other one to reflect any updates. Thank you.

          Tammy Fong made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Duplicate [ 3 ]
          Tammy Fong made changes -
          Link This issue duplicates LPS-18549 [ LPS-18549 ]
          Vicki Tsang made changes -
          Workflow Liferay Workflow 2.2 [ 248776 ] LPS Workflow [ 281373 ]
          Andrew Kim made changes -
          Workflow LPS Workflow [ 281373 ] Copy of LPS Workflow [ 425233 ]
          Andrew Kim made changes -
          Workflow Copy of LPS Workflow [ 425233 ] LPS Workflow [ 456842 ]
          Edward Gonzales made changes -
          Component/s Operations [ 14582 ]
          Andrew Kim made changes -
          Workflow LPS Workflow [ 456842 ] Copy 2 of LPS Workflow [ 489206 ]
          Andrew Kim made changes -
          Workflow Copy 2 of LPS Workflow [ 489206 ] LPS Workflow [ 521093 ]
          Randy Zhu made changes -
          Workflow LPS Workflow [ 521093 ] PUBLIC - LPS Generic Workflow [ 572932 ]
          Randy Zhu made changes -
          Workflow PUBLIC - LPS Generic Workflow [ 572932 ] Copy of PUBLIC - LPS Generic Workflow [ 607247 ]
          Randy Zhu made changes -
          Workflow Copy of PUBLIC - LPS Generic Workflow [ 607247 ] PUBLIC - LPS Generic Workflow [ 639176 ]
          Randy Zhu made changes -
          Workflow PUBLIC - LPS Generic Workflow [ 639176 ] PUBLIC - LPS General Workflow [ 732567 ]
          Randy Zhu made changes -
          Issue Type Sub-Task [ 5 ] Technical Task [ 23 ]
          Randy Zhu made changes -
          Workflow PUBLIC - LPS General Workflow [ 732567 ] PUBLIC - LPS Technical Task Workflow [ 977230 ]
          Esther Sanz made changes -
          Component/s Fault Tolerance [ 20186 ]
          Component/s Core Infrastructure [ 14582 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          2d 20h 42m 1 Tammy Fong 06/Jul/11 10:35 PM

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 42 weeks, 4 days ago

                Development

                  Structure Helper Panel