PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-18680

Blog entries published in the same minute are placed in reverse order when using Oracle 10

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 5.2.X EE, 6.0.12 EE, 6.1.0 CE RC1
    • Fix Version/s: 6.1.30 EE GA3, 6.2.0 CE M2
    • Labels:
      None
    • Environment:
      Tomcat 6.0.32 + Oracle 10.2.0.1.0. 5.2.x Revision 84698.
      Tomcat 6.0.32 + Oracle 10.2.0.1.0. 6.0.x Revision 84668.
      Tomcat 6.0.32 + Oracle 10.2.0.1.0. 6.1.x Revision 84698.
    • Fix Priority:
      2
    • Similar Issues:
      Show 5 results 

      Description

      When a user publishes multiple blog entries during the same minute (an example would be publishing 2 blog entries at 3:15 pm), the order of the blog entries is arranged in a reverse order. This only occurs when the user is using Oracle 10 as a database.

      Here are the steps to reproduce the issue:

      1. Start Liferay using the Oracle database
      2. Add a blogs portlet
      3. Publish 2 or 3 blogs entries in the same minute; name the entries "Blog 1", "Blog 2", and "Blog 3"
      4. Check the order. Instead of being ordered from most to least recently published (Blog 3, Blog 2, Blog 1), the entries are ordered from least to most recently published (Blog 1, Blog 2, Blog 3)
      5. Publish an entry titled "Blog 4" during the next minute (Meaning that if the user published the first 2 or 3 blog entries at 3:15 pm, Blog 4 should be published at 3:16 pm or later)
      6. Check the order. Blog 4 will be the first blog entry listed (The new order will be "Blog 4, Blog 1, Blog 2, Blog 3"

        Activity

        Ken Duenwald added a comment - - edited

        This issue is also reproduced when using PostgreSQL 8.

        Ken Duenwald added a comment - - edited

        No Longer Reproducible on:
        Tomcat 7.0.27 + Oracle 10. Portal 6.0.x EE GIT ID: 90b6d56b01ce0c8869009de6dc9aefebc2464aaa.
        Tomcat 7.0.27 + Oracle 10. Portal 6.1.x EE GIT ID: 08a3dd30aa15ba1fb7be48647929e844f9b3a1dc.
        Tomcat 7.0.27 + Oracle 10. Portal 6.2.x GIT ID: 286f7f53533ad2fc79e2f995202c93235b78078d.

        The blog entries are now ordered properly from most recent to least recent, even when published in the same minute.

        Unable to verify in latest 6.1.x EE due to LPS-30084; 6.1.x EE was tested at GIT ID that was before the bug from LPS-30084 (September 14, 2012).


          People

          • Assignee:
            Ken Duenwald
            Reporter:
            Ken Duenwald
            Recent user:
            Randy Zhu
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 34 weeks, 6 days ago

              Development

                Structure Helper Panel