Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 6.1.0 CE RC1
    • Fix Version/s: 6.1.1 CE GA2
    • Labels:
      None
    • Environment:
      GlassFish 3.1, Liferay Portal 6.1.X,
    • Similar Issues:
      Show 4 results 

      Description

      Many times we faced this problem:

      [#|2011-08-03T11:06:48.060+0000|INFO|oracle-glassfish3.1|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=75;_ThreadName=Thread-1;|11:06:48,060 WARN [BaseDB:377] ORA-01430: column being added already exists in table: alter table WorkflowDefinitionLink add typePK LONG;

      #]

      [#|2011-08-03T11:06:48.064+0000|INFO|oracle-glassfish3.1|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=75;_ThreadName=Thread-1;|11:06:48,063 INFO [UpgradeProcess:199] Upgrading com.liferay.portal.upgrade.v6_1_0.UpgradeAsset

      #]

      [#|2011-08-03T11:06:48.071+0000|INFO|oracle-glassfish3.1|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=75;_ThreadName=Thread-1;|11:06:48,071 INFO [UpgradeProcess:199] Upgrading com.liferay.portal.upgrade.v6_1_0.UpgradeAdminPortlets

      #]

      [#|2011-08-03T11:06:48.106+0000|INFO|oracle-glassfish3.1|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=75;_ThreadName=Thread-1;|11:06:48,106 INFO [UpgradeProcess:199] Upgrading com.liferay.portal.upgrade.v6_1_0.UpgradeBlogs

      #]

      [#|2011-08-03T11:06:48.113+0000|INFO|oracle-glassfish3.1|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=75;_ThreadName=Thread-1;|11:06:48,112 INFO [UpgradeProcess:199] Upgrading com.liferay.portal.upgrade.v6_1_0.UpgradeDocumentLibrary

      #]

      [#|2011-08-03T11:06:48.180+0000|INFO|oracle-glassfish3.1|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=75;_ThreadName=Thread-1;|11:06:48,173 ERROR [MainServlet:201] com.liferay.portal.kernel.events.ActionException: com.liferay.portal.kernel.upgrade.UpgradeException: com.liferay.portal.kernel.upgrade.UpgradeException: java.sql.SQLException: ORA-00904: "NAME": invalid identifier

      com.liferay.portal.kernel.events.ActionException: com.liferay.portal.kernel.upgrade.UpgradeException: com.liferay.portal.kernel.upgrade.UpgradeException: java.sql.SQLException: ORA-00904: "NAME": invalid identifier

      at com.liferay.portal.events.StartupAction.run(StartupAction.java:57)
      at com.liferay.portal.servlet.MainServlet.processStartupEvents(MainServlet.java:1238)
      at com.liferay.portal.servlet.MainServlet.init(MainServlet.java:198)
      at javax.servlet.GenericServlet.init(GenericServlet.java:244)
      at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1439)
      at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1241)
      at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:5032)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:5319)
      at com.sun.enterprise.web.WebModule.start(WebModule.java:500)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:917)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:901)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:755)
      at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1980)
      at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1630)
      at com.sun.enterprise.web.WebApplication.start(WebApplication.java:100)
      at org.glassfish.internal.data.EngineRef.start(EngineRef.java:130)
      at org.glassfish.internal.data.ModuleInfo.start(ModuleInfo.java:269)
      at org.glassfish.internal.data.ApplicationInfo.start(ApplicationInfo.java:286)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:461)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:240)
      at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:370)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:360)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:370)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1067)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:96)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1247)
      at org.glassfish.deployment.autodeploy.AutoOperation.run(AutoOperation.java:145)
      at org.glassfish.deployment.autodeploy.AutoDeployer.deploy(AutoDeployer.java:577)
      at org.glassfish.deployment.autodeploy.AutoDeployer.deployAll(AutoDeployer.java:463)
      at org.glassfish.deployment.autodeploy.AutoDeployer.run(AutoDeployer.java:395)
      at org.glassfish.deployment.autodeploy.AutoDeployer.run(AutoDeployer.java:380)
      at org.glassfish.deployment.autodeploy.AutoDeployService$1.run(AutoDeployService.java:213)
      at java.util.TimerThread.mainLoop(Timer.java:512)
      at java.util.TimerThread.run(Timer.java:462)
      Caused by: com.liferay.portal.kernel.upgrade.UpgradeException: com.liferay.portal.kernel.upgrade.UpgradeException: java.sql.SQLException: ORA-00904: "NAME": invalid identifier

      at com.liferay.portal.kernel.upgrade.UpgradeProcess.upgrade(UpgradeProcess.java:205)
      at com.liferay.portal.upgrade.UpgradeProcessUtil._upgradeProcess(UpgradeProcessUtil.java:80)
      at com.liferay.portal.upgrade.UpgradeProcessUtil.upgradeProcess(UpgradeProcessUtil.java:37)
      at com.liferay.portal.events.StartupHelper.upgradeProcess(StartupHelper.java:73)
      at com.liferay.portal.events.StartupHelperUtil.upgradeProcess(StartupHelperUtil.java:40)
      at com.liferay.portal.tools.DBUpgrader.upgrade(DBUpgrader.java:99)
      at com.liferay.portal.events.StartupAction.doRun(StartupAction.java:126)
      at com.liferay.portal.events.StartupAction.run(StartupAction.java:51)
      ... 33 more
      Caused by: com.liferay.portal.kernel.upgrade.UpgradeException: java.sql.SQLException: ORA-00904: "NAME": invalid identifier

      at com.liferay.portal.kernel.upgrade.UpgradeProcess.upgrade(UpgradeProcess.java:205)
      at com.liferay.portal.kernel.upgrade.UpgradeProcess.upgrade(UpgradeProcess.java:221)
      at com.liferay.portal.upgrade.UpgradeProcess_6_1_0.doUpgrade(UpgradeProcess_6_1_0.java:58)
      at com.liferay.portal.kernel.upgrade.UpgradeProcess.upgrade(UpgradeProcess.java:202)
      ... 40 more
      Caused by: java.sql.SQLException: ORA-00904: "NAME": invalid identifier

      at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
      at oracle.jdbc.ttc7.TTIoer.processError(TTIoer.java:289)
      at oracle.jdbc.ttc7.Oall7.receive(Oall7.java:573)
      at oracle.jdbc.ttc7.TTC7Protocol.doOall7(TTC7Protocol.java:1891)
      at oracle.jdbc.ttc7.TTC7Protocol.parseExecuteDescribe(TTC7Protocol.java:830)
      at oracle.jdbc.driver.OracleStatement.doExecuteQuery(OracleStatement.java:2391)
      at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:2672)
      at oracle.jdbc.driver.OraclePreparedStatement.executeUpdate(OraclePreparedStatement.java:589)
      at oracle.jdbc.driver.OraclePreparedStatement.executeQuery(OraclePreparedStatement.java:527)
      at com.sun.gjc.spi.jdbc40.PreparedStatementWrapper40.executeQuery(PreparedStatementWrapper40.java:646)
      at com.liferay.portal.upgrade.v6_1_0.UpgradeDocumentLibrary.updateFileRanks(UpgradeDocumentLibrary.java:149)
      at com.liferay.portal.upgrade.v6_1_0.UpgradeDocumentLibrary.doUpgrade(UpgradeDocumentLibrary.java:43)
      at com.liferay.portal.kernel.upgrade.UpgradeProcess.upgrade(UpgradeProcess.java:202)
      ... 43 more

      #]

      [#|2011-08-03T11:06:48.181+0000|INFO|oracle-glassfish3.1|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=75;_ThreadName=Thread-1;|Stopping the server due to unexpected startup errors|#]

        Activity

        A M added a comment -

        Any workaround for this? I am also facing the same problem and i am stuck. Even can't start my tomcat because of this.

        Armaz Mellati added a comment -

        I can not believe nobody has fixed this yet. This affects EVERYONE who has already been upgraded to 6.0.12. This means this affects all of us EE users. After hours of research I have found the following:

        It fails because the com.liferay.portal.upgrade.v6_1_0.UpgradeDocumentLibrary.updateFileRanks repeats what has already been done by com.liferay.portal.upgrade.v6_0_12.UpgradeDocumentLibrary.updateFileRanks. Both processes first do a select on NAME and FOLDERID columns, and the remove them. Obviously the next one cannot find the columns when doing select and it throws an Exception.
        I see there is another process called UpgradeProcess_6_0_12_to_6_1_0. That one should kick inn instead of UpgradeProcess_6_1_0. It seams to me it is unpredictable which one will actually run first.

        PLEASE fix this as soon as possible. This is pretty critical for all EE users.

        Armaz Mellati added a comment -

        After some more research, I found the easiest workaround/solution. I had simply needed to put this in portal-ex.properties upgrade.processes=\
        com.liferay.portal.upgrade.UpgradeProcess_6_0_0,\
        com.liferay.portal.upgrade.UpgradeProcess_6_0_1,\
        com.liferay.portal.upgrade.UpgradeProcess_6_0_2,\
        com.liferay.portal.upgrade.UpgradeProcess_6_0_3,\
        com.liferay.portal.upgrade.UpgradeProcess_6_0_5,\
        com.liferay.portal.upgrade.UpgradeProcess_6_0_6,\
        com.liferay.portal.upgrade.UpgradeProcess_6_0_12_to_6_1_0,\
        com.liferay.portal.upgrade.UpgradeProcess_6_1_1

        this tells the upgradering process to do UpgradeProcess_6_0_12_to_6_1_0 instead of the default value UpgradeProcess_6_1_0.

        Mika Koivisto added a comment -

        Armaz if you are using EE you need to follow EE upgrade instructions. It seems the original poster is also upgrading from a non CE version because the first error is that the column already exists. a CE release will by default upgrade from previous CE release. If you are not on the previous CE release then you need to make sure you have a upgrade process in place for the version you are on.

        Mika Koivisto added a comment -

        This seems to be a configuration issue.

        huma added a comment -

        what about the solution of these issue


          People

          • Votes:
            2 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 8 weeks, 2 days ago

              Development

                Structure Helper Panel