PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-20127

Manage Pages - Dragging a child page onto a parent page and saving does not change the display order

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.1 CE GA2, 6.1.10 EE GA1, 6.1.20 EE GA2
    • Fix Version/s: 6.1.30 EE GA3, 6.2.0 CE M2
    • Component/s: WCM, WCM > Sites Management
    • Labels:
    • Environment:
      Tomcat 6.0.32 + MySQL 5. 6.0.x Revision 87154.
      Tomcat 7.0.25 + MySQL 5. 6.1.x GIT ID: 6d6b8814da7c7295ed4cab8420e070793361f856.
      Tomcat 7.0.25 + MySQL 5. 6.2.x GIT ID: 71ce8e940ae12bae24e2a5e14cf3f836bb291915.
    • Branch Version/s:
      6.1.x
    • Backported to Branch:
      Committed
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      This bug only occurs when dragging a child page on top of a parent page. Dragging a child page within the tree under a parent page works fine.

      Steps to reproduce:
      1. Add a Parent Page with two child pages, "Child Page 1" and "Child Page 2"
      2. Click Manage > Page, and click the arrow next to "Public Pages" to display the Welcome Page and Parent Page.
      3. Click the arrow next to the Parent Page to display the two child pages. (Shown in OriginalDisplayOrder.JPG)
      4. Click Child Page 1 and drag Child Page 1 to the Parent Page. The user will see a green circle with a plus sign before releasing (Shown in DropOnTopOfParent.JPG). This will move Child Page 1 to the bottom of the tree (Shown in NewDisplayOrder.JPG)
      5. Click "Save"
      6. Click the arrow next to the Parent Page. Notice that the display order has reverted back to the original order.
      7. Refresh the page. The new display order will not have saved; mousing over the Parent Page will reveal the original display order instead of the new one(Shown in WhatLiferayDisplays.JPG)

      **
      However, drag and drop within the tree works. If the user drags and drops within the tree (Shown in DropWithinTree.JPG), the display order will update correctly and display correctly in Liferay.

      1. DropOnTopOfParent.JPG
        22 kB
      2. DropWithinTree.JPG
        20 kB
      3. NewDisplayOrder.JPG
        22 kB
      4. OriginalDisplayOrder.JPG
        20 kB
      5. WhatLiferayDisplays.JPG
        19 kB

        Activity

        Brian Chiu added a comment -

        Able to reproduce on:
        Tomcat 7.0.25 + MySQL 5. 6.1.x GIT ID: 6d6b8814da7c7295ed4cab8420e070793361f856.
        Tomcat 7.0.25 + MySQL 5. 6.2.x GIT ID: 71ce8e940ae12bae24e2a5e14cf3f836bb291915.

        Brian Chiu added a comment - - edited

        Reproduced on:
        Tomcat 6.0.33 + MySQL 5. Portal 6.0.x EE GIT ID: 412a25b22dd58c88809de8aa65330b894741ed9a.
        Tomcat 7.0.27 + MySQL 5. Portal 6.1.x EE GIT ID: fcbd234ede504e0996d6fe6a385507fce2519c8e.

        Also ran into LPS-29228 while testing this.

        Michael Saechang added a comment -

        Committed on:
        Portal 6.2.x GIT ID: fe96faffa7a4f28d9ea036ffa691835a0d2a54a1.

        Mark Jin added a comment -

        PASSED Manual Testing following the steps in the description.

        Reproduced on:
        Tomcat 7.0 + MySQL 5. Portal 6.1.20 EE GA2.

        Refresh the page. The new display order doesn't saved.

        Fixed on:
        Tomcat 7.0 + MySQL 5. Portal 6.1.x EE GIT ID: dff75a26e7bc006090724d7906dc023e8ad5267d.
        Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 02fcacb2dd1bf930e32bd320cdc8c6ccb236b5d0.

        The new display order is saved.

        Michael Saechang added a comment -

        Thank you Mark for testing. Closing as 'Fixed'.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 16 weeks, 2 days ago

              Development

                Structure Helper Panel