Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-2141

Task Management Porltet unable to install

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Unresolved
    • Affects Version/s: 5.2.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      tomcat 6 bundle

      Description

      When installing Task Management portlet via the control panel, I get the following output:

      18:24:04,878 INFO [AutoDeployDir:183] Processing tms-portlet-5.2.0.1.war
      18:24:04,880 INFO [PortletAutoDeployListener:67] Deploying package as a web application
      18:24:04,881 INFO [PortletAutoDeployListener:77] Copying portlets for /opt/liferay/liferay-portal-5.2.1/deploy/tms-portlet-5.2.0.1.war
      Expanding: /opt/liferay/liferay-portal-5.2.1/deploy/tms-portlet-5.2.0.1.war into /opt/liferay/liferay-portal-5.2.1/tomcat-6.0.18/temp/20090218182404883
      Copying 1 file to /opt/liferay/liferay-portal-5.2.1/tomcat-6.0.18/temp/20090218182404883/WEB-INF
      Copying 1 file to /opt/liferay/liferay-portal-5.2.1/tomcat-6.0.18/temp/20090218182404883/WEB-INF/classes
      Copying 1 file to /opt/liferay/liferay-portal-5.2.1/tomcat-6.0.18/temp/20090218182404883/WEB-INF/classes
      Copying 1 file to /opt/liferay/liferay-portal-5.2.1/tomcat-6.0.18/temp/20090218182404883/WEB-INF
      Copying 1 file to /opt/liferay/liferay-portal-5.2.1/tomcat-6.0.18/temp/20090218182404883/META-INF
      java.lang.NullPointerException
      at com.liferay.portal.deploy.auto.WAIAutoDeployer.copyXmls(WAIAutoDeployer.java:74)
      at com.liferay.portal.tools.deploy.BaseDeployer.deployDirectory(BaseDeployer.java:452)
      at com.liferay.portal.tools.deploy.BaseDeployer.deployFile(BaseDeployer.java:739)
      at com.liferay.portal.tools.deploy.BaseDeployer.deployFile(BaseDeployer.java:676)
      at com.liferay.portal.tools.deploy.BaseDeployer.deploy(BaseDeployer.java:407)
      at com.liferay.portal.deploy.auto.PortletAutoDeployer.autoDeploy(PortletAutoDeployer.java:99)
      at com.liferay.portal.deploy.auto.PortletAutoDeployListener.deploy(PortletAutoDeployListener.java:84)
      at com.liferay.portal.kernel.deploy.auto.AutoDeployDir.processFile(AutoDeployDir.java:196)
      at com.liferay.portal.kernel.deploy.auto.AutoDeployDir.scanDirectory(AutoDeployDir.java:144)
      at com.liferay.portal.kernel.deploy.auto.AutoDeployScanner.run(AutoDeployScanner.java:60)
      18:24:05,172 INFO [PortletAutoDeployListener:87] Portlets for /opt/liferay/liferay-portal-5.2.1/deploy/tms-portlet-5.2.0.1.war copied successfully. Deployment will start in a few seconds.

      I'm unable to install by manually copying the war to the deploy folder or even the webapps folder.

        Attachments

          Activity

            People

            Assignee:
            support-lep@liferay.com SE Support
            Reporter:
            boden Boden Larson (Inactive)
            Participants of an Issue:
            Recent user:
            Esther Sanz
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              11 years, 6 weeks, 2 days ago

                Packages

                Version Package