Details

    • Similar Issues:
      Show 5 results 

      Description

      Hello,

      when changing a site template (e.g. removing a portlet, changing the page layout), the sites that have been build using this template don't reflect those changes.

      1) Create a Site Template "Templ" (make sure Allow Modifications and Allow Layout Additions are checked)
      2) Add some portlets to the template, set a page layout
      3) Create an organization "Orga"
      4) Create a site for the organization and use the template "Templ"
      5) Verify the site looks as defined by the template
      6) Edit the site template (remove one portlet, change the page layout)
      7) Navigate to the "Orga" site ... changes are not picked up, everything remains as previously defined.

      Alex

        Activity

        Hide
        Alex Weirig added a comment -

        Hello,

        I just tested the "administrator" workaround on trunk (rev 94254) but it didn't work.

        I edited the template (added the language portlet) and visited the site as test@liferay.com user but the site didn't show the new portlet.

        Alex

        Show
        Alex Weirig added a comment - Hello, I just tested the "administrator" workaround on trunk (rev 94254) but it didn't work. I edited the template (added the language portlet) and visited the site as test@liferay.com user but the site didn't show the new portlet. Alex
        Hide
        Jorge Ferrer added a comment -

        This has been fixed by several other tickets (look for recently closed tickets in the Component "Site Templates & Page Templates" for a list).

        Show
        Jorge Ferrer added a comment - This has been fixed by several other tickets (look for recently closed tickets in the Component "Site Templates & Page Templates" for a list).
        Hide
        Paul Piao (Inactive) added a comment -

        FAILED Manual Testing following steps in description.

        Failed on:
        Tomcat 7.0 + MySQL 5. 6.2.x GIT ID: 18fe20dc76cab039caabeeb5aa5951dd48deabe1.
        I found I delete portlet not be deleted. But Page layout is working.

        Show
        Paul Piao (Inactive) added a comment - FAILED Manual Testing following steps in description. Failed on: Tomcat 7.0 + MySQL 5. 6.2.x GIT ID: 18fe20dc76cab039caabeeb5aa5951dd48deabe1. I found I delete portlet not be deleted. But Page layout is working.
        Hide
        Jorge Ferrer added a comment -

        Hey Paul,

        I did some tests with this and this worked in all scenarios I could imagine, including deleting portlets, moving them, etc. So I'm resolving it again.

        If it still does not work for you, please provide more detailed instructions of the failing test.

        Show
        Jorge Ferrer added a comment - Hey Paul, I did some tests with this and this worked in all scenarios I could imagine, including deleting portlets, moving them, etc. So I'm resolving it again. If it still does not work for you, please provide more detailed instructions of the failing test.
        Hide
        Paul Piao (Inactive) added a comment -

        PASSED Manual Testing following steps in description.

        Fixed on:
        Tomcat 7.0 + MySQL 5. 6.2.x GIT ID: d8633f74f55d7ef7756a08ecbb04942a9e3812fd.
        On fixed ID. Changes in Site Template do show in site.

        Show
        Paul Piao (Inactive) added a comment - PASSED Manual Testing following steps in description. Fixed on: Tomcat 7.0 + MySQL 5. 6.2.x GIT ID: d8633f74f55d7ef7756a08ecbb04942a9e3812fd. On fixed ID. Changes in Site Template do show in site.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              3 years, 7 weeks, 6 days ago

              Development

                Structure Helper Panel