Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.0.6 GA, 6.0.12 EE, 6.1.0 CE RC1, 6.1.1 CE GA2, 6.1.20 EE GA2
    • Labels:
      None
    • Environment:
    • Branch Version/s:
      6.1.x
    • Backported to Branch:
      Committed
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      The creole WYSIWYG editor allows you to change table properties. However, none of these settings are saved and are lost after every save.

      1. Add a Wiki portlet to the page.
      2. Edit the front page (or any other page)
      3. Select Creole for the format
      4. Click the Table button
      5. Change the width, cell spacing, and/or border size.
      6. Click OK.
      All your settings will be applied to the table and it will look correct in the editor.
      7. Fill in some data in the table, just so the cell isn't empty
      8. Publish the page.
      All your settings will be gone.

      The same applies when you try to edit the table/cell properties of an existing table.

      All the bad fields are highlighted in the attached images.

      The root issue here is that the creole syntax doesn't support these properties so we should not be displaying the option to change them when using creole.

        Issue Links

          Activity

          Iliyan Peychev added a comment -

          If you read Wiki Creole specification, you will see that all these properties are not mentioned. That is the only reason we have not implemented them.

          The dialog is the standard dialog from CKEditor, which is supposed to work with HTML, where these properties (attributes) are supported.
          It seems there are two ways to resolve this issue:
          1. Create simplified dialog for tables and replace the default one in CKEditor.
          2. Add support for these properties (attributes) as Liferay extension to the specification.

          Jeffrey Yang added a comment -

          FAILED Manual Testing following the steps in the description.
          Reproduced on:
          Tomcat 7.0 + MySQL 5. Portal 6.1.x EE GIT ID: ac0a7f2a669723a0f81594a26ce052d73d57e26a.
          Tomcat 7.0 + MySQL 5. Portal 6.1.x CE GIT ID: 3a4b7d205f0fa3c4f437500862dafee10c797e46.
          Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 71213361b6c18d85c669facc1c2db7b168c9ad0f1.

          The values inputted into the table properties do not carry over to posted table.

          Jeffrey Yang added a comment -

          Committed on:
          Portal 6.2.x GIT ID: 0ad2088a49815ccce1851daff9811460371d81bd.

          Jeffrey Yang added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0 + MySQL 5. Portal 6.2.x GIT ID: 0ad2088a49815ccce1851daff9811460371d81bd.
          Non-configurable options no longer show.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 10 weeks, 3 days ago

                Development

                  Structure Helper Panel