Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-24458

Navigation portlet: Change of display style after an unauthnorized access

    Details

      Description

      I log in with an Administrator user account. I enter a page where I have added the navigation portlet. I have explicitly chosen display style no 6.
      I copy the link of the remove operation on the portlet.
      I log out.
      I log in as a plain User account
      I paste the link on the browser address and get an error page (no address found)
      From that point the navigation portlet has lost its display style which is reset to 1.

      Strangely enough I have set
      navigation.display.style.options=6
      in portal-ext.properties to avoid this but it doesn't seem to work, since the display style options are not narrowed to a signle option (i.e. 6), when configuring the portlet, hence the style falls back to 1.

      Any ideas?

        Attachments

          Activity

            People

            Assignee:
            sophia.zhang Sophia Zhang
            Reporter:
            moudatsos Michael Moudatsos (Inactive)
            Participants of an Issue:
            Recent user:
            Marta Elicegui
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              8 years, 3 weeks, 5 days ago

                Packages

                Version Package
                6.1.0 CE RC1
                --Sprint 11/12
                6.2.0 CE M2