Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-25319

Remote Staging in 6.1 EA shows confusing descriptions for publishing to live child pages


    • Type: Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.1.1 CE GA2
    • Fix Version/s: 6.1.X EE
    • Component/s: Staging, UI Infrastructure
    • Labels:
    • Similar Issues:
      Show 5 results 


      The default behavior when publishing a page to Remote Live is to "include all descendant pages." The Publish To Remote Live Now dialog correctly displays that but if you click on the Change link, the expanded options show a checkbox "Include all descendant pages" which is unchecked. If you check it, the descriptive text next to the page ("include all descendant pages") vanishes, and when you publish the page, the descendant pages are not published. So, it appears that the language of that checkbox is incorrect since it is the opposite of the actual functionality. This is confusing to the user. I've seen this on 6.1.x for a while and verified it again today on the latest 6.1.x.

      Steps to Reproduce:
      1. Set up remote publishing.
      2. Go to the remote staging site page
      3. Click the "Staging" drop-down
      4. Click "Publish to Remote Live Now"
      5. Under the Pages section, Options will say "Include all descendent pages."
      6. Click on the "+ Change" link
      7. "Include all descendent pages" is not checked
      8. Check "Include all descendent pages."
      9. Options will now be blank.

      (Also... according to Webster dictionary... descendent is spelled descendant.)


        bruno.basto Bruno Basto added a comment -

        Just started reviewing :)

        Sent from GH.

        bruno.basto Bruno Basto added a comment - Just started reviewing :) Sent from GH .


          • Assignee:
            bruno.basto Bruno Basto
            jenny.chen Jenny Chen
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            1 Start watching this issue


            • Created:
              Days since last comment:
              1 year, 36 weeks, 5 days ago



                  Structure Helper Panel