Details

    • Branch Version/s:
      6.1.x
    • Backported to Branch:
      Committed
    • Epic/Theme:
    • Similar Issues:
      Show 4 results 

      Description

      Steps to reproduce:

      1. Go to Control Panel --> Web Content
      2. Create a web content (type "General") and publish.
      3. Edit the web content and change the type to "blog"
      4. Go the Advanced Search of this portlet and search for "General" --> You will find the web content

      The content should not appear in this situation. It seems the old version is still indexed...

        Issue Links

          Activity

          Hide
          Igor Beslic added a comment -

          Reproduced in 6.1.11EE
          Can't reproduce in 6.2EE

          Show
          Igor Beslic added a comment - Reproduced in 6.1.11EE Can't reproduce in 6.2EE
          Hide
          Igor Beslic added a comment -

          I've recreated problem at current CE git trunk.

          Show
          Igor Beslic added a comment - I've recreated problem at current CE git trunk.
          Hide
          Igor Beslic added a comment -

          Juan, I just change type criteria what means:
          We will fix reported issue, but still we have to create UI immprovement ticket accordinge jorge's and yours comments.

          Thank you!

          Show
          Igor Beslic added a comment - Juan, I just change type criteria what means: We will fix reported issue, but still we have to create UI immprovement ticket accordinge jorge's and yours comments. Thank you!
          Hide
          Brian Chan added a comment -

          Please resubmit this. Most of the changes in that fix were not necesarry. The parameter order for the finders are right because they are based on the order in which they appear in JournalArticle.

          The order in which they are "used" in SQL can change constantly, so it should not be in that order. Fix should be much simpler. Thx.

          Show
          Brian Chan added a comment - Please resubmit this. Most of the changes in that fix were not necesarry. The parameter order for the finders are right because they are based on the order in which they appear in JournalArticle. The order in which they are "used" in SQL can change constantly, so it should not be in that order. Fix should be much simpler. Thx.
          Show
          Brian Chan added a comment - Not merging: https://github.com/brianchandotcom/liferay-portal/pull/4564
          Show
          Juan Fernández added a comment - Resubmitted: https://github.com/brianchandotcom/liferay-portal/pull/4571
          Hide
          Alberto Montero added a comment -

          Hi,

          The ticket says that backport to 6.1 was commited, but the github repository does not show it. Any problem with backport?

          Alberto

          Show
          Alberto Montero added a comment - Hi, The ticket says that backport to 6.1 was commited, but the github repository does not show it. Any problem with backport? Alberto
          Hide
          Michael Saechang added a comment -

          Committed on:
          6.1.x GIT ID: 418e52e836a6627112c5c8cdb5b74059b5ad261a.
          6.2.x GIT ID: 5d64c8a12e5fbb2ca87af3ce50b4a0c2ef64f9aa.

          Show
          Michael Saechang added a comment - Committed on: 6.1.x GIT ID: 418e52e836a6627112c5c8cdb5b74059b5ad261a. 6.2.x GIT ID: 5d64c8a12e5fbb2ca87af3ce50b4a0c2ef64f9aa.
          Hide
          Luyang Tan (Inactive) added a comment - - edited

          PASSED Manual Testing following the steps in the description.

          Reproduced on:
          Tomcat 7.0 + MySQL 5. 6.1.0 CE-GA1.

          When I go the Advanced Search and search for "General" -->I will find the web content.

          Fixed on:
          Tomcat 7.0 + MySQL 5. 6.1.x EE GIT ID: ce9ca6f0a809c3e3f8907bd997792b164fc94816.
          Tomcat 7.0 + MySQL 5. 6.2.x GIT ID: 15601dbe369e902a0e60973d7da1d55766ce2a14.

          When I go the Advanced Search and search for "General" -->I will not find the web content.

          Show
          Luyang Tan (Inactive) added a comment - - edited PASSED Manual Testing following the steps in the description. Reproduced on: Tomcat 7.0 + MySQL 5. 6.1.0 CE-GA1. When I go the Advanced Search and search for "General" -->I will find the web content. Fixed on: Tomcat 7.0 + MySQL 5. 6.1.x EE GIT ID: ce9ca6f0a809c3e3f8907bd997792b164fc94816. Tomcat 7.0 + MySQL 5. 6.2.x GIT ID: 15601dbe369e902a0e60973d7da1d55766ce2a14. When I go the Advanced Search and search for "General" -->I will not find the web content.
          Hide
          Michael Saechang added a comment -

          Thank you Luyang for testing. Closing as 'Fixed'.

          Show
          Michael Saechang added a comment - Thank you Luyang for testing. Closing as 'Fixed'.
          Hide
          Alberto Montero added a comment -

          Changed from Bug to Technical Support.

          Show
          Alberto Montero added a comment - Changed from Bug to Technical Support.
          Hide
          Edward Gonzales added a comment -

          Slated for inclusion in 6.1.1 CE GA2

          Show
          Edward Gonzales added a comment - Slated for inclusion in 6.1.1 CE GA2

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 48 weeks, 2 days ago

                Development

                  Structure Helper Panel