Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 5.2.2
    • Fix Version/s: 6.0.2 RC
    • Component/s: Collaboration > Wiki
    • Labels:
      None
    • Environment:
      all
    • Similar Issues:
      Show 5 results 

      Description

      If a wiki page title contains special characters as dashes (ALT+0150), these characters are not displayed correctly. In the case of a dash nothing is displayed.

      This problem causes that a page created via the add child functionality cannot be referenced from wiki page text.

      Step to reproduce the problem
      1. Create a child page containing a dash (ALT+0150) in the title and copy the title to the clipboard.
      2. Paste the title in a wiki text and create a link.
      3. Save the page.
      4. The link is red and clicking on it brings you to the form to create a new page (title WITHOUT the dash)

        Activity

        Gerald Ortner added a comment - - Restricted to

        Additional Info.

        Using the step sequence above the problem described in LPS-1037 is NOT solved. With an apostroph in the title this behavior can also be reproduced.

        Nicolas added a comment - - Restricted to

        I also noticed this issue on my Liferay SE trunk rel 5.2.3 rev 29480.
        Special characters are not displayed correctly.
        You can test it by creating a wiki post call - testé - for example.
        You should noticed that It is not possible to edit the post content.
        Even more important, it is NO LONGER POSSIBLE TO DELETE the post via the ui which is very bothering.
        Regards,
        Nico

        Rafał Piotrowski added a comment - - Restricted to

        The same applies to other letters with diacritical marks (i.e. ą, ę, ś) in wiki page name.
        It is present also in current trunk version of portal (rev 44608).

        Ivan Cheung added a comment -

        You should be fine as long as you select the right database character set and collation. (utf-8).

        Ivan Cheung added a comment -

        Fixed at least in 6.0.2 RC. Use the right character set and collation


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              4 years, 35 weeks, 3 days ago

              Development

                Structure Helper Panel