Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-26029

Blog portlet preferences are lost when adding a new page with blog pagetemplate

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.1.0 CE GA1, 6.1.20 EE GA2, 6.2.0 CE M2
    • Fix Version/s: 6.2.0 CE M3, 7.0.0 M3
    • Environment:
      Tomcat 7.0 + MySQL 5. 6.1.x GIT ID: f1ec1510962651d57317b3f74eb841e801e6c279.
      Tomcat 7.0 + MySQL 5. 6.2.x GIT ID: 8bc08bc9434a7a98e554722c706c66ca8e578f67.
    • Fix Priority:
      3

      Description

      After adding blog-porlet to a page and edited its display preferences the preferences are lost if a new page with blog page template is added.
      Steps to reproduce:
      1) Add blog-portlet to an existing page A (not created with blog-template).
      2) Configure > Display settings > Maximum Items to Display => change to show 1 > Save
      3) Add 2 new blog entries
      4) Confirm that only 1 show, as set in preferences.
      5) Create new page using default blog page template (page B)
      6) Open new page B > Shows both blog entries
      7) Open page A > Shows both blog entries

      This can be verified also in the database by watching portletpreferences table with portletid ='33'.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  5 years, 21 weeks ago

                  Packages

                  Version Package
                  6.2.0 CE M3
                  7.0.0 M3