Details

    • Type: Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 6.1.10 EE GA1
    • Fix Version/s: 6.1.20 EE GA2
    • Component/s: Legacy
    • Labels:
      None
    • Environment:
      Linux 2.6.32-300.7.1.el5uek x86_64
      apache 2.2.3
      mod_jk 1.2.32
      tomcat 7.0.25

      Description

      Apache mod_jk url redirection is not working for some of the URLs. URL redirection works correctly for Liferay 6.0 + Tomcat bundle. Looks like the issue is related to length of the URL. If I have a shorter URL, the site works as expected. If the url is long, it is redirecting to the tomcat url, without the port. In the following example # 1 works, #2 fails.
      1.
      http://10.160.255.40/web/guest/home?p_auth=wVxP8XXt&p_p_auth=FGceSTY8&p_p_id=49&p_p_lifecycle=1&p_p_state=normal&p_p_mode=view
      2.
      http://10.160.255.40/web/guest/home?p_auth=wVxP8XXt&p_p_auth=FGceSTY8&p_p_id=49&p_p_lifecycle=1&p_p_state=normal&p_p_mode=view&_49_struts_action=%2Fmy_sites%2Fview

        Activity

        mika.koivisto Mika Koivisto added a comment -

        It could be mod_jk configuration issue. I've never had any problems with mod_proxy_ajp.

        dzhang18 david added a comment -

        We are working on Liferay 6.2 CE GA5. After using mod_jk redirection, buttons such as Reply, Reply with quote, post a new thread, etc., do not work any more. The redirection just hang there until click the url link above to successfully connect to the target pages. But Quick Reply works well. The differences between Reply and Quick reply is the URL length, I guess. I don't know if other people on this board have experienced the same problem and how to fix it. Thanks in advance.

        dzhang18 david added a comment -

        Steps to reproduce the URL too long issue after redirection with mod_jk:

        1. After mod_jk redirection from Apache 2 HTTP Server to Tomcat 7 on Cent OS 7 completed, enter Message Board
        2. Click the thread (message) to add comments
        3. In the message board, click Reply
        4. A blank page displayed and hang there forever?
        5. Click redirection link in the link box, it can be successfully connected to the target page
        6. Quick Reply works well


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              30 weeks, 5 days ago

              Development

                Subcomponents