PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-27211

Kaleo My Workflow Tasks Search does not work when searching by asset title for Single Approver Version 1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 6.0.X EE, 6.1.30 EE GA3, 6.2.0 CE M2
    • Fix Version/s: 6.1.30 EE GA3, 6.2.0 CE M4
    • Labels:
      None
    • Environment:
    • Epic/Theme:
    • Fix Priority:
      4
    • Similar Issues:
      Show 4 results 

      Description

      Kaleo search does not take the asset title into account when searching if the assets are for Single Approver (Version 1).

      Steps to reproduce:

      1. Deploy the kaleo-web plugin
      2. Navigate to Control Panel > Workflow Configuration
      3. Configure Blogs Entry to Single Approver (Version 1)
      4. Submit a blog entry for publication
      5. Navigate to Control Panel > My Workflow Tasks
      6. Enter the name of the blog entry into the search bar and click Search
        • No results will return
      7. Use advanced search and search by the blog entry title and the type
        • This will work if the search is configured to match any field, but will not work if configured to match all fields

      However, this search worked fine when I used Category Specific Approval.

        Issue Links

          Activity

          Brian Chiu added a comment - - edited

          Reproduced on:
          Tomcat 7.0.27 + MySQL 5. Portal 6.1.x EE GIT ID: 0194e5337a7371291163a76a24d98f2417adaa27.
          Plugins 6.1.x EE GIT ID: b1a9ce0be1b678af68b0a28f4777c54198bbf936.

          Still cannot search by Title.

          priti added a comment -

          In order to resolve this defect need to change workflow_search_results.jspf Please review attached hook

          Tina Tian added a comment -

          The root reason of this problem is: it is not searching by "Asset Title" column, it is searching by "Task" column.

          It means you can get results by searching by "review" which is name of "Task".

          Michael Han added a comment -

          Just as Tina commented, this really isn't a bug. It's a missing feature. Essentially: the Kaleo workflow doesn't store information like asset titles and etc. Instead, it stores a references to the real asset.

          In order to search by asset title, we need to actually index the tasks in Kaleo against the search engine. Thus, we need to index each workflow task and then search against that index.

          This should be a new user story and new feature

          Igor Beslic added a comment -

          Hi all... we changed user interface (see LPS-31737) so that user is aware he searches for "task name" not the asset title.

          JR Houn added a comment -

          Hey Guys -

          Based on the comments - sounds like we should either be
          a. closing this out as Won't Fix
          or
          b. closing this out as a duplicate of LPS-31737

          What do you guys think? The sooner we resolve this issue, the sooner we'll be able to move forward w/ a dependent project.

          Brian Chiu added a comment - - edited

          Closing this as a "won't fix" based on the previous comments. Since the user now knows that the search is by task and not by title, this is no longer an issue.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 24 weeks, 6 days ago

                Development

                  Structure Helper Panel