PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-27297

Apache Derbry DB - load content document (.docx) throws SQL Exception

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.1.0 CE GA1
    • Fix Version/s: 6.2.0 CE M4
    • Environment:
      Windows 7 Enterprise, Apache Derby (Java DB) 10.8.2.2, Java 1.6 + Tomcat 7 (as supplied with Liefray Tomcat bundle) - vanilla install
    • Similar Issues:
      Show 5 results 

      Description

      Sql error for Derby when uploading a .docx file.

      Action to reproduce:
      1) Add 'Documents and Media' portlet to a page
      2) Create a folder named (for example) 'working area'
      3) Add a 'Basic Document'
      4) Upload a .docx word file.
      5) Logs contain stack trace:

      15:25:36,525 ERROR [JDBCExceptionReporter:75] Syntax error: Encountered "xml" at line 1, column 115.
      15:25:36,528 ERROR [SerialDestination:104] Unable to process message {destinationName=liferay/document_library_raw_metadat
      , response=null, responseDestinationName=null, responseId=null, payload=com.liferay.portal.repository.liferayrepository.mo
      FileVersion@19648c1, values={principalPassword=null, principalName=10196, companyId=10154}}
      com.liferay.portal.kernel.messaging.MessageListenerException: com.liferay.portlet.dynamicdatamapping.StorageException: com
      rtal.kernel.exception.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.SQLGrammarE
      ould not insert: [com.liferay.portlet.dynamicdatamapping.model.impl.DDMContentImpl]
      at com.liferay.portal.kernel.messaging.BaseMessageListener.receive(BaseMessageListener.java:31)
      at com.liferay.portal.kernel.messaging.InvokerMessageListener.receive(InvokerMessageListener.java:65)
      at com.liferay.portal.kernel.messaging.SerialDestination$1.run(SerialDestination.java:101)
      at com.liferay.portal.kernel.concurrent.ThreadPoolExecutor$WorkerTask._runTask(ThreadPoolExecutor.java:669)
      at com.liferay.portal.kernel.concurrent.ThreadPoolExecutor$WorkerTask.run(ThreadPoolExecutor.java:580)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: com.liferay.portlet.dynamicdatamapping.StorageException: com.liferay.portal.kernel.exception.SystemException: c
      portal.kernel.dao.orm.ORMException: org.hibernate.exception.SQLGrammarException: could not insert: [com.liferay.portlet.dy
      pping.model.impl.DDMContentImpl]
      at com.liferay.portlet.dynamicdatamapping.storage.BaseStorageAdapter.create(BaseStorageAdapter.java:56)
      at com.liferay.portlet.dynamicdatamapping.storage.StorageEngineImpl.create(StorageEngineImpl.java:43)
      at com.liferay.portlet.dynamicdatamapping.storage.StorageEngineUtil.create(StorageEngineUtil.java:35)
      at com.liferay.portlet.documentlibrary.service.impl.DLFileEntryMetadataLocalServiceImpl.updateFileEntryMetadata(DL
      tadataLocalServiceImpl.java:144)
      at com.liferay.portlet.documentlibrary.service.impl.DLFileEntryMetadataLocalServiceImpl.updateFileEntryMetadata(DL
      tadataLocalServiceImpl.java:81)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:112)
      at com.liferay.portal.spring.transaction.TransactionInterceptor.invoke(TransactionInterceptor.java:71)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
      at com.liferay.portal.spring.aop.ChainableMethodAdvice.invoke(ChainableMethodAdvice.java:59)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
      at com.liferay.portal.spring.aop.ChainableMethodAdvice.invoke(ChainableMethodAdvice.java:59)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
      at com.liferay.portal.spring.aop.ChainableMethodAdvice.invoke(ChainableMethodAdvice.java:59)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
      at com.liferay.portal.spring.aop.ServiceBeanAopProxy.invoke(ServiceBeanAopProxy.java:211)
      at $Proxy185.updateFileEntryMetadata(Unknown Source)
      at com.liferay.portlet.documentlibrary.service.DLFileEntryMetadataLocalServiceUtil.updateFileEntryMetadata(DLFileE
      aLocalServiceUtil.java:298)
      at com.liferay.portlet.documentlibrary.util.RawMetadataProcessorImpl.saveMetadata(RawMetadataProcessorImpl.java:12
      at com.liferay.portlet.documentlibrary.util.RawMetadataProcessorUtil.saveMetadata(RawMetadataProcessorUtil.java:89
      at com.liferay.portlet.documentlibrary.messaging.RawMetadataProcessorMessageListener.doReceive(RawMetadataProcesso
      tener.java:33)
      at com.liferay.portal.kernel.messaging.BaseMessageListener.receive(BaseMessageListener.java:25)
      ... 5 more
      Caused by: com.liferay.portal.kernel.exception.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: org.hibern
      on.SQLGrammarException: could not insert: [com.liferay.portlet.dynamicdatamapping.model.impl.DDMContentImpl]
      at com.liferay.portal.service.persistence.impl.BasePersistenceImpl.processException(BasePersistenceImpl.java:193)
      at com.liferay.portlet.dynamicdatamapping.service.persistence.DDMContentPersistenceImpl.updateImpl(DDMContentPersi
      java:373)
      at com.liferay.portlet.dynamicdatamapping.service.persistence.DDMContentPersistenceImpl.updateImpl(DDMContentPersi
      java:1)
      at com.liferay.portal.service.persistence.impl.BasePersistenceImpl.update(BasePersistenceImpl.java:257)
      at com.liferay.portlet.dynamicdatamapping.service.impl.DDMContentLocalServiceImpl.addContent(DDMContentLocalServic
      73)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:112)
      at com.liferay.portal.spring.transaction.TransactionInterceptor.invoke(TransactionInterceptor.java:71)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
      at com.liferay.portal.spring.aop.ChainableMethodAdvice.invoke(ChainableMethodAdvice.java:59)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
      at com.liferay.portal.spring.aop.ChainableMethodAdvice.invoke(ChainableMethodAdvice.java:59)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
      at com.liferay.portal.spring.aop.ChainableMethodAdvice.invoke(ChainableMethodAdvice.java:59)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
      at com.liferay.portal.spring.aop.ServiceBeanAopProxy.invoke(ServiceBeanAopProxy.java:211)
      at $Proxy197.addContent(Unknown Source)
      at com.liferay.portlet.dynamicdatamapping.service.DDMContentLocalServiceUtil.addContent(DDMContentLocalServiceUtil
      at com.liferay.portlet.dynamicdatamapping.storage.XMLStorageAdapter.doCreate(XMLStorageAdapter.java:93)
      at com.liferay.portlet.dynamicdatamapping.storage.BaseStorageAdapter.create(BaseStorageAdapter.java:50)
      ... 29 more
      Caused by: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.SQLGrammarException: could not insert:
      y.portlet.dynamicdatamapping.model.impl.DDMContentImpl]
      at com.liferay.portal.dao.orm.hibernate.ExceptionTranslator.translate(ExceptionTranslator.java:30)
      at com.liferay.portal.dao.orm.hibernate.SessionImpl.flush(SessionImpl.java:122)
      at com.liferay.portal.kernel.dao.orm.ClassLoaderSession.flush(ClassLoaderSession.java:218)
      at com.liferay.portal.service.persistence.BatchSessionImpl.update(BatchSessionImpl.java:95)
      at com.liferay.portal.service.persistence.BatchSessionUtil.update(BatchSessionUtil.java:49)
      at com.liferay.portlet.dynamicdatamapping.service.persistence.DDMContentPersistenceImpl.updateImpl(DDMContentPersi
      java:368)
      ... 50 more
      Caused by: org.hibernate.exception.SQLGrammarException: could not insert: [com.liferay.portlet.dynamicdatamapping.model.im
      ntImpl]
      at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:92)
      at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:66)
      at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2454)
      at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2874)
      at org.hibernate.action.EntityInsertAction.execute(EntityInsertAction.java:79)
      at org.hibernate.engine.ActionQueue.execute(ActionQueue.java:273)
      at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:265)
      at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:184)
      at org.hibernate.event.def.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:321)
      at org.hibernate.event.def.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:51)
      at org.hibernate.impl.SessionImpl.flush(SessionImpl.java:1216)
      at com.liferay.portal.dao.orm.hibernate.SessionImpl.flush(SessionImpl.java:119)
      ... 54 more
      Caused by: java.sql.SQLSyntaxErrorException: Syntax error: Encountered "xml" at line 1, column 115.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory40.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement20.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement30.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement40.<init>(Unknown Source)
      at org.apache.derby.jdbc.Driver40.newEmbedPreparedStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
      at com.mchange.v2.c3p0.impl.NewProxyConnection.prepareStatement(NewProxyConnection.java:213)
      at sun.reflect.GeneratedMethodAccessor65.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.springframework.jdbc.datasource.LazyConnectionDataSourceProxy$LazyConnectionInvocationHandler.invoke(LazyCo
      aSourceProxy.java:376)
      at $Proxy4.prepareStatement(Unknown Source)
      at org.hibernate.jdbc.AbstractBatcher.getPreparedStatement(AbstractBatcher.java:534)
      at org.hibernate.jdbc.AbstractBatcher.prepareStatement(AbstractBatcher.java:116)
      at org.hibernate.jdbc.AbstractBatcher.prepareStatement(AbstractBatcher.java:109)
      at org.hibernate.jdbc.AbstractBatcher.prepareBatchStatement(AbstractBatcher.java:244)
      at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2411)
      ... 63 more
      Caused by: java.sql.SQLException: Syntax error: Encountered "xml" at line 1, column 115.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.SQLExceptionFactory40.wrapArgsForTransportAcrossDRDA(Unknown Source)
      ... 87 more
      Caused by: ERROR 42X01: Syntax error: Encountered "xml" at line 1, column 115.
      at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
      at org.apache.derby.impl.sql.compile.ParserImpl.parseStatement(Unknown Source)
      at org.apache.derby.impl.sql.GenericStatement.prepMinion(Unknown Source)
      at org.apache.derby.impl.sql.GenericStatement.prepare(Unknown Source)
      at org.apache.derby.impl.sql.conn.GenericLanguageConnectionContext.prepareInternalStatement(Unknown Source)
      ... 81 more
      15:25:55,519 ERROR [JDBCExceptionReporter:75] Syntax error: Encountered "xml" at line 1, column 115.
      15:25:55,520 ERROR [SerialDestination:104] Unable to process message {destinationName=liferay/document_library_raw_metadat
      , response=null, responseDestinationName=null, responseId=null, payload=com.liferay.portal.repository.liferayrepository.mo
      FileVersion@1758498, values={principalPassword=null, principalName=10196, companyId=10154}}
      com.liferay.portal.kernel.messaging.MessageListenerException: com.liferay.portlet.dynamicdatamapping.StorageException: com
      rtal.kernel.exception.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.SQLGrammarE
      ould not insert: [com.liferay.portlet.dynamicdatamapping.model.impl.DDMContentImpl]
      at com.liferay.portal.kernel.messaging.BaseMessageListener.receive(BaseMessageListener.java:31)
      at com.liferay.portal.kernel.messaging.InvokerMessageListener.receive(InvokerMessageListener.java:65)
      at com.liferay.portal.kernel.messaging.SerialDestination$1.run(SerialDestination.java:101)
      at com.liferay.portal.kernel.concurrent.ThreadPoolExecutor$WorkerTask._runTask(ThreadPoolExecutor.java:669)
      at com.liferay.portal.kernel.concurrent.ThreadPoolExecutor$WorkerTask.run(ThreadPoolExecutor.java:580)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: com.liferay.portlet.dynamicdatamapping.StorageException: com.liferay.portal.kernel.exception.SystemException: c
      portal.kernel.dao.orm.ORMException: org.hibernate.exception.SQLGrammarException: could not insert: [com.liferay.portlet.dy
      pping.model.impl.DDMContentImpl]
      at com.liferay.portlet.dynamicdatamapping.storage.BaseStorageAdapter.create(BaseStorageAdapter.java:56)
      at com.liferay.portlet.dynamicdatamapping.storage.StorageEngineImpl.create(StorageEngineImpl.java:43)
      at com.liferay.portlet.dynamicdatamapping.storage.StorageEngineUtil.create(StorageEngineUtil.java:35)
      at com.liferay.portlet.documentlibrary.service.impl.DLFileEntryMetadataLocalServiceImpl.updateFileEntryMetadata(DL
      tadataLocalServiceImpl.java:144)
      at com.liferay.portlet.documentlibrary.service.impl.DLFileEntryMetadataLocalServiceImpl.updateFileEntryMetadata(DL
      tadataLocalServiceImpl.java:81)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:112)
      at com.liferay.portal.spring.transaction.TransactionInterceptor.invoke(TransactionInterceptor.java:71)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
      at com.liferay.portal.spring.aop.ServiceBeanAopProxy.invoke(ServiceBeanAopProxy.java:211)
      at $Proxy185.updateFileEntryMetadata(Unknown Source)
      at com.liferay.portlet.documentlibrary.service.DLFileEntryMetadataLocalServiceUtil.updateFileEntryMetadata(DLFileE
      aLocalServiceUtil.java:298)
      at com.liferay.portlet.documentlibrary.util.RawMetadataProcessorImpl.saveMetadata(RawMetadataProcessorImpl.java:12
      at com.liferay.portlet.documentlibrary.util.RawMetadataProcessorUtil.saveMetadata(RawMetadataProcessorUtil.java:89
      at com.liferay.portlet.documentlibrary.messaging.RawMetadataProcessorMessageListener.doReceive(RawMetadataProcesso
      tener.java:33)
      at com.liferay.portal.kernel.messaging.BaseMessageListener.receive(BaseMessageListener.java:25)
      ... 5 more
      Caused by: com.liferay.portal.kernel.exception.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: org.hibern
      on.SQLGrammarException: could not insert: [com.liferay.portlet.dynamicdatamapping.model.impl.DDMContentImpl]
      at com.liferay.portal.service.persistence.impl.BasePersistenceImpl.processException(BasePersistenceImpl.java:193)
      at com.liferay.portlet.dynamicdatamapping.service.persistence.DDMContentPersistenceImpl.updateImpl(DDMContentPersi
      java:373)
      at com.liferay.portlet.dynamicdatamapping.service.persistence.DDMContentPersistenceImpl.updateImpl(DDMContentPersi
      java:1)
      at com.liferay.portal.service.persistence.impl.BasePersistenceImpl.update(BasePersistenceImpl.java:257)
      at com.liferay.portlet.dynamicdatamapping.service.impl.DDMContentLocalServiceImpl.addContent(DDMContentLocalServic
      73)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:112)
      at com.liferay.portal.spring.transaction.TransactionInterceptor.invoke(TransactionInterceptor.java:71)
      at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
      at com.liferay.portal.spring.aop.ServiceBeanAopProxy.invoke(ServiceBeanAopProxy.java:211)
      at $Proxy197.addContent(Unknown Source)
      at com.liferay.portlet.dynamicdatamapping.service.DDMContentLocalServiceUtil.addContent(DDMContentLocalServiceUtil
      at com.liferay.portlet.dynamicdatamapping.storage.XMLStorageAdapter.doCreate(XMLStorageAdapter.java:93)
      at com.liferay.portlet.dynamicdatamapping.storage.BaseStorageAdapter.create(BaseStorageAdapter.java:50)
      ... 23 more
      Caused by: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.SQLGrammarException: could not insert:
      y.portlet.dynamicdatamapping.model.impl.DDMContentImpl]
      at com.liferay.portal.dao.orm.hibernate.ExceptionTranslator.translate(ExceptionTranslator.java:30)
      at com.liferay.portal.dao.orm.hibernate.SessionImpl.flush(SessionImpl.java:122)
      at com.liferay.portal.kernel.dao.orm.ClassLoaderSession.flush(ClassLoaderSession.java:218)
      at com.liferay.portal.service.persistence.BatchSessionImpl.update(BatchSessionImpl.java:95)
      at com.liferay.portal.service.persistence.BatchSessionUtil.update(BatchSessionUtil.java:49)
      at com.liferay.portlet.dynamicdatamapping.service.persistence.DDMContentPersistenceImpl.updateImpl(DDMContentPersi
      java:368)
      ... 38 more
      Caused by: org.hibernate.exception.SQLGrammarException: could not insert: [com.liferay.portlet.dynamicdatamapping.model.im
      ntImpl]
      at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:92)
      at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:66)
      at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2454)
      at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2874)
      at org.hibernate.action.EntityInsertAction.execute(EntityInsertAction.java:79)
      at org.hibernate.engine.ActionQueue.execute(ActionQueue.java:273)
      at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:265)
      at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:184)
      at org.hibernate.event.def.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:321)
      at org.hibernate.event.def.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:51)
      at org.hibernate.impl.SessionImpl.flush(SessionImpl.java:1216)
      at com.liferay.portal.dao.orm.hibernate.SessionImpl.flush(SessionImpl.java:119)
      ... 42 more
      Caused by: java.sql.SQLSyntaxErrorException: Syntax error: Encountered "xml" at line 1, column 115.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory40.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement20.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement30.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement40.<init>(Unknown Source)
      at org.apache.derby.jdbc.Driver40.newEmbedPreparedStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareStatement(Unknown Source)
      at com.mchange.v2.c3p0.impl.NewProxyConnection.prepareStatement(NewProxyConnection.java:213)
      at sun.reflect.GeneratedMethodAccessor65.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.springframework.jdbc.datasource.LazyConnectionDataSourceProxy$LazyConnectionInvocationHandler.invoke(LazyCo
      aSourceProxy.java:376)
      at $Proxy4.prepareStatement(Unknown Source)
      at org.hibernate.jdbc.AbstractBatcher.getPreparedStatement(AbstractBatcher.java:534)
      at org.hibernate.jdbc.AbstractBatcher.prepareStatement(AbstractBatcher.java:116)
      at org.hibernate.jdbc.AbstractBatcher.prepareStatement(AbstractBatcher.java:109)
      at org.hibernate.jdbc.AbstractBatcher.prepareBatchStatement(AbstractBatcher.java:244)
      at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2411)
      ... 51 more
      Caused by: java.sql.SQLException: Syntax error: Encountered "xml" at line 1, column 115.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.SQLExceptionFactory40.wrapArgsForTransportAcrossDRDA(Unknown Source)
      ... 75 more
      Caused by: ERROR 42X01: Syntax error: Encountered "xml" at line 1, column 115.
      at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
      at org.apache.derby.impl.sql.compile.ParserImpl.parseStatement(Unknown Source)
      at org.apache.derby.impl.sql.GenericStatement.prepMinion(Unknown Source)
      at org.apache.derby.impl.sql.GenericStatement.prepare(Unknown Source)
      at org.apache.derby.impl.sql.conn.GenericLanguageConnectionContext.prepareInternalStatement(Unknown Source)
      ... 69 more

        Activity

        Aniceto P Madrid added a comment -

        Does this happen only with docx files? Does this happen with any docx file? Have you tried older Liferay versions with derby + docs? Is there any property or setting which may affect docx files like open office?
        Have you tried to upload such kind of files to Liferay 6.2.0m4?
        Thanks

        Aniceto P Madrid added a comment -

        This issue is not reproducible and the submitter has not responded within 10 days.  This issue can be closed


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 51 weeks, 1 day ago

              Development

                Structure Helper Panel